How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIXITMAN Your Own Question
FIXITMAN
FIXITMAN, Master Technician
Category: Volvo
Satisfied Customers: 17143
Experience:  ASE MASTER CERTIFICATION, AA DEGREE AUTOMOTIVE/DIESEL
1627031
Type Your Volvo Question Here...
FIXITMAN is online now
A new question is answered every 9 seconds

ABS light came on, brake system failure light came on, stop

Customer Question

ABS light came on, brake system failure light came on, stop car light came on. Pulled over, key will not come out of ignition, car will not start now.
JA: Does the engine turn over? How old is the battery?
Customer: No it will not turn over. Lights still work, fuel pump still coming on, no obvious signs of battery
JA: What is the model/year of your Volvo?
Customer: 2005 s40
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: If just the battery, yes
JA: Anything else you think the mechanic should know?
Customer: No problems prior to this issue. No problems with brakes noted.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Volvo Mechanic about your situation and then connect you two.
Submitted: 4 months ago.
Category: Volvo
Expert:  FIXITMAN replied 4 months ago.

Hello, my name is***** these other system may be working this is the first sign of a low battery possibly due to an alternator failure. You need to have the battery load tested first. If it is low then it will either need to be recharged or replaced. Once that is done the alternator will need to be checked. If these are fine then it may have a bad negative cable ground connection or the ignition switch may be failing. I hope this helps. If you need anything else please let me know.