How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Enes Your Own Question
Enes, VOLVO Master Technician
Category: Volvo
Satisfied Customers: 5464
Type Your Volvo Question Here...
Enes is online now
A new question is answered every 9 seconds

Volvo S70: I have 2000 S70 non-turbo. At first start each day

Customer Question

I have 2000 S70 non-turbo. At first start each day the engine won't rev past 2000 RPM in Park or in gear and will only go 5 MPH, (appears to be in Limp Mode). After about 3 minutes when the temperature gage reaches the center tick mark (normal range) it instantly corrects itself and engine runs fine the remainder of the day even if the engine returns to a temperature below the normal range. I replaced the thermostat and temperature sender. No error code and no check engine light. Car has about 140,000 miles on it. Any help is appreciated, thank you.
Submitted: 5 months ago.
Category: Volvo
Expert:  Pete replied 5 months ago.
Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay. In some cases I have seen issues with the mass air flow sensor send incorrect signals causing this fault here.It causes the computer to run at a different air/fuel ratio and limits power and acceleration and usually once the mass air flow sensor warms up it will start to operate properly.This sensor is also common to not set any fault codes when this issue occurs like this here.This sensor is inline with the air inlet tubing leading from the engine air filter box to your throttle body.In some cases the sensor can be removed and cleaned to correct this here.If you have not done this I would clean it and see if this resolves the fault.It may be a good idea to have the fuel pressure tested as well to see if this is a low pressure issue with a weak fuel pump until the pump warms up as this can sometimes occur as well. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete
Customer: replied 5 months ago.
Hi Pete, I had previously cleaned the MAF and Throttle Body. Fuel pressure checks out ok. Problem still exists. As noted earlier, once the engine temperature gage reads normal, (center tick on gage) the problem resolves itself. This problem only occurs in the morning, (typically over 60 degrees so I'm not in a cold climate). Once it's resolves itself for the first time of the day the car runs great, even if the engine is cold later in the day.
Expert:  Pete replied 5 months ago.
If you can try unplugging the mass air flow sensor before starting the engine,then start the engine when cold like this and see if it runs any better and let me know.
Customer: replied 5 months ago.
no difference when unplugged
Expert:  Pete replied 5 months ago.
Unfortunately this is a difficult one for me to answer myself here.I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.Thanks Pete
Expert:  Enes replied 5 months ago.
almost sounds you like have bad throttle etm on that car