How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Enes Your Own Question
Enes
Enes, VOLVO Master Technician
Category: Volvo
Satisfied Customers: 5468
Experience:  15+YEARS WITH VOLVO AS THE MASTER VOLVO MECHANIC&Ase
20168386
Type Your Volvo Question Here...
Enes is online now
A new question is answered every 9 seconds

My 2005 Volvo S60 (2.4L) non turbo idles very rough and got

Customer Question

My 2005 Volvo S60 (2.4L) non turbo idles very rough and got a code P0300. This is what I have done so far: New plugs, New air filter, New fuel pressure sensor, new oil trap hoses. I did noticed that the exhaust makes a "puff.. puff.. puff" sound spits out moisture which smells like fireworks (sulfur). My BOSCH scanner showed the following freeze frame: Throttle position 5.5%; Eng speed 843 rpm; Barometer pressure 28.6" Hg; Calculated Engine load 47.5%; MAF sensor 1.00 lb/M; Ambient Air Temp 59deg; Coolant 77 deg; IAT 68 deg; Ignition Timing Advance 9.0 deg;
Short Term Fuel Trim Bank 1 - 8.6%; Long Term Fuel Trim Bank 1 0%; veh speed 0mph;
Absolute Load Value 7.5%; Fuel Rail Pressure 55psi; Fuel sys 1 closed; relative throttle position 4.7 %; Commanded Throttle Actuator Control 5.5%; ABS TPS B 22%; ABS TPS C 59%; Accelerator pedal position D 7.1%; ACC POS E 7.5%; EVAP PURGE 0%; Commanded Equivalence Ration (Rich/Lean) 0.994; Control Module Voltage 13.632 VPlease help
Thanks,
Peter
Submitted: 6 months ago.
Category: Volvo
Expert:  Greg replied 6 months ago.
Peter is this the only code you have P0300.Can you do a exhaust back pressure test , possible catalytic converter is bad .What colour was the old spark plugs youm replaced .What make of plugs did you use when you replaced them.Rgds Greg
Customer: replied 6 months ago.
Hello Greg,
Yes, P0300 is the only code. Old plugs were kind of blown with smooth texture. Don't remember the old plugs brand. New brand is Autolite platnium
Customer: replied 6 months ago.
I removed the downstream O2 sensor. Rough idle stills there.
I removed the upstream O2 sensor. Rough idle stills there.
Customer: replied 6 months ago.
Sorry Greg,
It's been taken too long for your reply. I no longer need your response.
Expert:  Greg replied 6 months ago.
Okay no problem and sorry internet was out .. Greg
Expert:  Enes replied 6 months ago.
FROM WHAT YOU SAYING SOUNDS YOU HAVE BAD IGNITION COILS THEY DO GO BAD REMOVE COIL AND YOU SEE MOST TIME WHEN YOU PEEL THAT RUBBER BOOT HAIR LINE CRACKS BEST REPLACE ALL COILS