How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Enes Your Own Question
Enes
Enes, VOLVO Master Technician
Category: Volvo
Satisfied Customers: 4904
Experience:  15+YEARS WITH VOLVO AS THE MASTER VOLVO MECHANIC&Ase
20168386
Type Your Volvo Question Here...
Enes is online now
A new question is answered every 9 seconds

Boat & heavy equipment mechanic of 30 years and hating volvo

Customer Question

boat & heavy equipment mechanic of 30 years and hating volvo fuel issues how experienced are you on 01 v70 xc bosch fuel
JA: Thanks. Can you give me any more details about your issue?
Customer: replaced orings on injectors had a couple leaking spray carb cleaner and rpm picked up so bought kits cleaned and no filter baskests were in kits and one in injectors were gone no screens left so removed them and presure cleaned them and no engine wont catch got good fuel presure on crank trys to start but wont catch has new fuel filter as well last week
JA: OK got it. Last thing — Volvo Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 8 months ago.
Category: Volvo
Expert:  Edward replied 8 months ago.
Hello, Eddie here and I will try to help. Are you sure it's a fuel injector issue that's making it not run? We rarely see these injectors fail enough to make one not run, even if one went bad, it would run on 5 cyl. Are you sure you've got injector pulse when cranking ?
Customer: replied 8 months ago.
Yes I tested them when cleaning its the 2.3 5 cyl and fuel rail is full fuel pump working got 40 psi on crank and injectors are pulling voltage and car ran prior only thind different is no filter baskets in top of injector order online no local stock I can't imagine that would be issue the filters only catch debris it cranks over almost starts but won't go
Customer: replied 8 months ago.
Also put in new plugs over weekends and ran new wires to cops they were baked and split from heat with no loom left on them
Customer: replied 8 months ago.
I noticed rail is not fully pressurized after running pump to prime like it would show a fully pressurized rail but does show good pressure while cranking
Expert:  Edward replied 8 months ago.
So you've got spark to the plugs when cranking, and 40 psi, and injector pulse when cranking? correct?
Customer: replied 8 months ago.
Yes
Customer: replied 8 months ago.
Seem like its not staying pressurized like it should intake is getting fuel from injectors
Customer: replied 8 months ago.
I know its firing because it almost goes after cranking for 10 to 15seconds a real stumper to me
Customer: replied 8 months ago.
Are you still with me
Customer: replied 8 months ago.
I'm out man thanks any way sure your trying to carry on multiple convo thought I give it a try
Customer: replied 8 months ago.
Hello are you still with me I don't want to be charged for this if this is all I get I get 65 an hour for marine work and give a good diagnosis and repairs
Expert:  Edward replied 8 months ago.
Hello, sorry, I'm here, If you have fuel pressure, and spark to the plugs, and injector pulse. I think it should run, if you have compression, I mean that's all you need to get a bang. Is it setting any codes by chance?
Expert:  Edward replied 8 months ago.
Unplug the mass air flow sensor and leave it unplugged, see if it will run then.
Customer: replied 8 months ago.
No codes I've been through a load of troubleshooting there's nothing on my cars and trucksive never been able to fix I'll try that I'll let you know can't try it till morning I'm at my beach house and have close neighbors its 10:40 but I'll try in am I'll let you know
Expert:  Edward replied 8 months ago.
You have a code reader handy? or can you get one? I'd like to see what code it is setting, if any.
Expert:  Edward replied 8 months ago.
You did check it and nothing was stored?
Expert:  Edward replied 8 months ago.
See if you can make it run on starting fluid too. just for 10 seconds or so, easiest when somebody inside cranking it while you spray it right in the air intake near the air box. if it will run on starting fluid, then we know for 100% sure it's just fuel related. I gotta put a tranny in tom. but I should be back on tom. early pm. a grounder..lol fun. Let me know what happens.
Customer: replied 8 months ago.
I meant Ihaven't been able to fix I'm just flustered its mywifes car and we've had a couplevolvos and had good luck
I will see what blows you don't think those filter basket missing injectors would cause it not to go I wouldn't. Think so
Expert:  Edward replied 8 months ago.
You talking about the screen inside the injector right? near the bottom of it ?
Customer: replied 8 months ago.
Its at the top at rail end
Expert:  Edward replied 8 months ago.
Can you upload a picture of it?
Customer: replied 8 months ago.
They are pressed in they were spent no screens left non in stock local
Expert:  Edward replied 8 months ago.
and each injector has one? I don't know without looking?
Customer: replied 8 months ago.
You can figure them out the press in screen
Expert:  Edward replied 8 months ago.
The press in filter, yes, I know what your talking about now, I thought you meant on the spray side, that is just aluminum with some little holes in it, I doubt very seriously having some of those screens out would make it not run.
Expert:  Edward replied 8 months ago.
So your just missing some screens on a few of them?
Customer: replied 8 months ago.
The kit sent pintal caps and white nylon washers that go at bottom of injector mine didn't have pintel caps I used the white washers they insert into intake holes
Expert:  Edward replied 8 months ago.
When in question, and if it ran on starting fluid, I would pull the injector rail up, put some cardboard under it, and have somebody crank the engine while you look at each injector spray pattern. that will tell you if they are doing the job or not.
Expert:  Edward replied 8 months ago.
leave it hooked up to the fuel line and plugged in, and put some cardboard under it, and take a look with somebody cranking it. You know what I mean?
Customer: replied 8 months ago.
Yes I did yesterday upended them so I could see out window and they all mist evenly
Customer: replied 8 months ago.
And yes ihave obdll scanner
And picked up no codes
Expert:  Edward replied 8 months ago.
If it looks good, then I don't think fuel delivery is the issue . Did it just not crank one day going out to it? did it cut off and stall going down the road? what happened exactly?
Customer: replied 8 months ago.
No the first time I cranked it over it started ran a bit rough stalled and that's all she wrote
Customer: replied 8 months ago.
30 seconds
Customer: replied 8 months ago.
No you know why I'm ready to commit vechical suicide
Expert:  Edward replied 8 months ago.
lolll. Don't ghost ride it off a hill yet. Did you say the plugs were wet with gas? did you look at them? i don't know why, but these will sometimes just flood out after sitting, I believe the injectors leak down a bit, and they will just flood out, and sound like they don't have much compression when cranking. Does it sound normal cranking? or does it sound like it spins really fast?
Customer: replied 8 months ago.
Sounds normal I didn't have excessive fuel in cyl but had 3 nicely burnt plugs and cyl 4 and 5 were dark
I can smell fuel when cranking almost seems like it flooding then after 15 20 seconds acts like it want to start as if flooded then it just cranks out and compression on engine 135 to 150 not bad for 260 k but car has been fleet maintained
Expert:  Edward replied 8 months ago.
I follow you, so you put new plugs in it correct?
Customer: replied 8 months ago.
And 4 and 5 were the cyl that I accessed bad orings before this whole
abortion took place now you know why I'm have mechanical overdose
Customer: replied 8 months ago.
I hate feeling stupid there's not much I can fix
Customer: replied 8 months ago.
Consider myself a family smart dude with this shit
Customer: replied 8 months ago.
Fairly can't spell for crap though
Customer: replied 8 months ago.
What about the fuel pressure switch and this one dooesnt have the vac line going to it would that stop it for on starting and also checked all fuses and relauys
Customer: replied 8 months ago.
Going to walk dog be back in twenty let me know if you come up with something else
Customer: replied 8 months ago.
Yes new nkg split fires
Expert:  Edward replied 8 months ago.
You have a rail sensor in the end of the fuel rail with one torx that holds it in?
Expert:  Edward replied 8 months ago.
These rail sensors do give trouble. Can you get in the data stream to see if the processor is seeing the same fuel pressure that is showing on a mechanical gauge. These sensors give trouble. If not, hold it to the floor for a good 20 second crank time, and see if that fires it up. then unplug the MAF sensor and see if it fires up unplugged. usually that sensor (fuel pressure sensor) will throw a code though (not always)
Customer: replied 8 months ago.
OK I did try that trick like it was flooded open air up like it was flooded and opened cold air intake up as well pulled filter and left cover open and almost starts but ....haven't dicoed that maff yet so I'll try it and get back to you hope to have luck if I can get it running it may be eiasyer to figure out
Customer: replied 8 months ago.
Any way to test that fuel regulator they are family costly to replace don't want to put one in if its not bad but no codes just checked 20 min ago
Expert:  Edward replied 8 months ago.
alright, I test them by seeing what they are showing the ECM on a scanner, vs. what the real fuel pressure is on a mechanical gauge. I'm bout to call it a night here. Let me know what happens tom. thanks.
Customer: replied 8 months ago.
OK man have avoid one I'm sure it will get conquered eventually but time is something I don't have a lot of its the start of my season and the customers are piling its been a cold slow start up here in Maine so hate to fall behind early thanks for the advice
Expert:  Edward replied 8 months ago.
Absolutely, sounds good. Let me know what happens tom.

Related Volvo Questions