How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell A. Your Own Question
Russell A.
Russell A., Camera and Video Technician
Category: Camera and Video
Satisfied Customers: 5014
Experience:  30 years of experience as a TV station technician gives me a unique understanding of technical equipment issues.
24675295
Type Your Camera and Video Question Here...
Russell A. is online now
A new question is answered every 9 seconds

My camera will not load pictures.i plug it in and the creen

Customer Question

my camera will not load pictures.i plug it in and the creen flashes,but does not show up on my computer.it is a Eos rebel t3
JA: What's the exact make and model of the camera? And can you guesstimate how old it is?
Customer: 2 and a half years or so have never had a problem before
JA: What happened right before this popped up? What troubleshooting have you tried?
Customer: what can i do?
JA: Anything else you want the camera expert to know before I connect you?
Customer: no
Submitted: 2 months ago.
Category: Camera and Video
Expert:  Russell H. replied 2 months ago.

Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.

Try using a different USB cable. They have only four wires in them, and only one of two out of those has to break, for the device on the cable to be unrecognizable and unusable by the computer.

Also try a different USB port on the computer. Leave the plug of the cable in the USB port for at least 2 minutes before giving up - it may take a little time for the computer to recognize a device on a different USB port (if the one port is all that were wrong with things.)

And examine the plug-in or jack on the camera, for dirt. It might need cleaning (by scrubbing out with an old (but clean, and dry!) toothbrush, for at least 20 seconds, if it seems the least bit linty or dirty.

Let me know what results you get. I'll help more as needed.

Customer: replied 2 months ago.
I found the camera on tbe computer and was able to load the pictures. It wasn't the normal way. Will see about a new cable tomorrow
Expert:  Russell H. replied 2 months ago.

I presume you found the camera's icon and accessed the pictures on it that way.

Do you need further help with this question?