How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Russell A. Your Own Question

Russell A.
Russell A., Camera and Video Technician
Category: Camera and Video
Satisfied Customers: 5008
Experience:  30 years of experience as a TV station technician gives me a unique understanding of technical equipment issues.
Type Your Camera and Video Question Here...
Russell A. is online now
A new question is answered every 9 seconds

I have a d50 & a 28 - 105 mm lense. they worked great for

Customer Question

I have a d50 & a 28 - 105 mm lense. they worked great for years but now I get FFA and the camera will not fire. What is wrong? Jim
Submitted: 1 month ago.
Category: Camera and Video
Expert:  Russell H. replied 1 month ago.

Hi, thank you for contacting My name is Russell. I will do my best to provide the right answer to your question.

Does the camera fail with an FFA error displayed on it, with both/either lens assembly mounted on it?

If so, then what shows on the camera when it is powered up without any lens assembly mounted on it at the time of power-On ?

Customer: replied 1 month ago.
I have a 75 to 300 that is working but the 28 to 105 is failing with FFA
Expert:  Russell H. replied 1 month ago.

OK, that's good news.

Try cleaning the contacts on the lens mount of the 28-105 lens assembly, wiping gently with a clean dry soft cloth, gently so as to not remove the thin delicate coating on those contacts.

Then try that lens assembly again.

Let me know the result please.