How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Pete Your Own Question

Pete
Pete, Electronic Engineer
Category: Camera and Video
Satisfied Customers: 15775
Experience:  Over 16 years of experience installing and repairing electronics.
30970729
Type Your Camera and Video Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a Nikon F100 and two N80 film camera bodies, which

Customer Question

I have a Nikon F100 and two N80 film camera bodies, which I'm trying to use with two SB28 speedlights. This problem is the same on all the bodies with both speedlights: Using a Gossen Digi Pro flashmeter, and setting the SB28s to "A" (so the flash exposure is determined by the sb28 itself, instead of going through the camera on TTL), I get very accurate exposures. The problem arises when I set the sb28s to TTL and the camera bodies to Program - then the flash exposures are not accurate, usually with one to three stops of underexposure. When setting the bodies to Manual with the sb28s to TTL, the flash doesn't respond very well to changes in aperture, and underexposes by one to three stops. The same thing happens when setting the bodies to Aperture priority or Shutter priority. Ironically, when using the pop-up flashes on the N80 bodies, the strobe exposure is always right on. The problem only happens with the sb28s set to TTL. What am I doing wrong? Thanks... - Rob in Oregon
Submitted: 4 months ago.
Category: Camera and Video
Expert:  Pete replied 3 months ago.

Hi Rob,
My name is***** will try my best to help you with your question.

What lens are you using?

Not all lenses support the F100 or N80 light metering system.
--------------------
Kindly rate my service 5 stars at the top of your question page if my answer helped so I am rewarded for my time; tips appreciated :)
Otherwise please reply back if you need further assistance.
Pete.
--------------------

Customer: replied 3 months ago.
I'm using a 50mm f1.4 AF-D. It is supposed to do TTL flash metering with the F100 and N80.
Expert:  Pete replied 3 months ago.

Are all of the lens contacts clean on the lens and also on the camera body?

Do you have a different lens you can test on the cameras?

Customer: replied 3 months ago.
I have tried a 50mm f1.8 AF-D lens in addition to the 50mm f1.4 AF-D lens, a Sigma 24-135 f2.8-4 lens that was manufactured to work with Nikon's AF-D technology. The contacts on the camera and flash are clean. I have two N80 bodies and one F100 body, and the same problem exists no matter which one I use. You really don't know the answer to this, do you? Please refund my money. Thanks... - Rob
Expert:  Pete replied 3 months ago.

I am a user of this site, just like you.
I will opt out to see if the other techs have any further ideas.

Related Camera and Video Questions