How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Dan Your Own Question

Dan
Dan, Camera and Video Technician
Category: Camera and Video
Satisfied Customers: 1620
Experience:  25 Years CCTV, CATV, and SMATV setup and installation.
1567601
Type Your Camera and Video Question Here...
Dan is online now
A new question is answered every 9 seconds

My canon 70d is sending an error message that the lens

Customer Question

my canon 70d is sending an error message that the lens cannot communicate with camera. I have been using my 24-105 f4l lens for over a year now with no problems befor yesterday. How can I fix the problem ?
Submitted: 10 months ago.
Category: Camera and Video
Expert:  Dan replied 10 months ago.

Hello and thank you for your question, I look forward to assisting you today. Are you see the error 01 message?

Customer: replied 10 months ago.
error 01
Expert:  Dan replied 10 months ago.

Okay, try this. Power the camera down and remove the lens. With the lens off, power on press the shutter button as though you were taking a picture. Power down then reattach the lens but do not lock it in place and take another picture. Power down then lock the lens then power back up and try shooting normally.

Customer: replied 10 months ago.
I tried what you suggested and it worked for one frame, on the second shot I got the same error message......error 01
Expert:  Dan replied 10 months ago.

Did you clean the contacts on both the lens and camera body using alcohol?

Expert:  Dan replied 10 months ago.

Let me add some additional instructions to the lens reset I first sent. With the lens removed, take two photos then power the camera off. Turn the auto focus off on the lens and reattach it to the camera again without locking it in place and take one photo then check to see if the error is still visible. Turn the camera off and lock the lens in place and turn the auto focus back on and try taking another photo.