How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Russell H. Your Own Question

Russell H.
Russell H., Service Tech
Category: Camera and Video
Satisfied Customers: 9298
Experience:  8+ years of professional experience
Type Your Camera and Video Question Here...
Russell H. is online now
A new question is answered every 9 seconds

I have eos xi when iput it in program mode it will not auto

Customer Question

I have eos xi when iput it in program mode it will not auto change the shuter to correct setting.
Submitted: 6 months ago.
Category: Camera and Video
Expert:  Russell H. replied 6 months ago.

Hi, thank you for contacting My name is Russell. I will do my best to provide the right answer to your question.

Aperture priority and Program mode both do not set the shutter speed? then there may be a problem with your camera, that is not a setting.

But in case there is, you could do a Factory Reset of the camera's settings all back to defaults (except the time/date setting, etc.) That would erase your custom settings e.g. white balances, but would eliminate settings as the cause of the problem.

Other things to check on:

Try removing the batteries, and leaving the camera on a (dry, non-humid, non-dusty) shelf for overnight. Then put the batteries back in and try the camera again.

Then try cleaning the terminals in the battery compartment, after removing the batteries, first by rubbing off with a fresh pencil eraser, then by wiping the terminals off with cotton swabs moistened in rubbing alcohol, then letting them dry off for 5+ minutes with the battery compartment door open, then try turning the camera On again.

How long has the battery or batteries in the camera been in-use? If over a year, then you might possibly have a battery/batteries that are getting weak. Rechargeable batteries do get weaker with time, and eventually fail to deliver enough power to start up a device like a digital camera; they then need replacing. The replacement battery needs to be charged up for 6+ hours before its first use, owing to its having been on a shelf for a considerable time.

How old is the camera? in months or years since you bought it.

Has the camera been dropped or otherwise subjected to mechanical shock(s) in its lifetime?

Has the camera been operated in or subjected to, temperatures below 32 degrees F (freezing point) or above about 100 degrees F ?

Has it ever been subjected to a humidity higher than 85 % or gotten wet ?

Has the camera been operated in a gritty or sandy environment, such as a beach, a seaside, a construction site, or the like?

Related Camera and Video Questions