How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Freddy M. Your Own Question

Freddy M.
Freddy M., Camera Video Tech
Category: Camera and Video
Satisfied Customers: 18398
Experience:  Years of experience
15852642
Type Your Camera and Video Question Here...
Freddy M. is online now
A new question is answered every 9 seconds

I was given a Kodak Z990 recently. It is set to Spanish

Customer Question

Hi .. I was given a Kodak Z990 recently.
It is set to Spanish language. I have tried to change the default language to English, however, the Settings menu will not let me change it.
When I scroll down to get to "Language" ... it skips over it to the next configuration change
Nothing I do will "land" me on the language selection.
What is the work around for this, or do I need to re-install the camera's firmware? If so, how do I do that?
I hope you can help .. all the reviews I read rave about this camera and I would really love to use it.
Thanks
Paul
Submitted: 1 year ago.
Category: Camera and Video
Expert:  Freddy M. replied 1 year ago.
Hello my name is***** look forward to assisting and am very sorry to hear that you are having this problem.
You can use this download with the camera connected to the computer to update the firmware.
http://support.en.kodak.com/app/answers/detail/a_id/40577/~/kodak-easyshare-max-camera,-z990-firmware---windows-operating-systems/selected/true
If this did not work, please come back and let me know what happened when you tried it by clicking on reply to expert so we can continue.
If it did work, please don’t forget to leave a positive rating - it is greatly appreciated.
.
Customer: replied 1 year ago.
Hi Freddy .. I tried what you suggested, however, this did not work. Because the camera is set to Spanish, it was a little tough to follow the screen, however, with on line translation, I could follow it. It seems the re-flash of the firmware did run, however, I get the same result.If I go into the Settings menu to change the language, the language menu line is not "bright" like the other lines, and the cursor skips over it.Now what do I do?Please advise.Thanks
Paul
Expert:  Freddy M. replied 1 year ago.
Can you try switching it to a different mode before going into the settings? Some cameras will only allow you to change certain settings when in certain modes.
.
Customer: replied 1 year ago.
Hi .. How am I supposed to know how to switch to different modes that will work? I have turned the top dial to every different position and still no luck.It seems to me you are now guessing just as much as I am.It is also almost impossible to know what's going on on the camera screen as I do not speak Spanish, and every message / label on the screen UI is in Spanish.Please tell me you can either find the solution or not?Thanks
Paul
Expert:  Freddy M. replied 1 year ago.
It is not a guess as I told you in my last reply some models require it to be in a specific mode. You do not need to speak anything as the dial is what changes the mode. You already knew where the language option was since you said it skipped over it. I am opting out.
.
Customer: replied 1 year ago.
As I said, after the successful re-flash of the firmware, the language option is still not available. The cursor still skips over it.
You may notice I have already opened a Paypal case as you did not solve the problem.Thanks
Paul