How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Russell A. Your Own Question

Russell A.
Russell A., Camera and Video Technician
Category: Camera and Video
Satisfied Customers: 5011
Experience:  30 years of experience as a TV station technician gives me a unique understanding of technical equipment issues.
24675295
Type Your Camera and Video Question Here...
Russell A. is online now
A new question is answered every 9 seconds

The power goes out after a couple of shots even when the battery

Customer Question

The power goes out after a couple of shots even when the battery has been fully recharged and replaced with new batteries, on both my rebel xt and xs.
Submitted: 1 year ago.
Category: Camera and Video
Expert:  Freddy M. replied 1 year ago.
.
Hello my name is***** look forward to assisting and am very sorry to hear that you are having this problem. I want to warn you that it is possible you will need to replace a part in order to fix this. There are a few different things that can cause this and a couple different parts so we would need to troubleshoot to find out for sure. What model is this? How old is it? What kind of batteries are you using?
.
Customer: replied 1 year ago.
Both cameras are having this issue. The first is Rebel XT DS126071 and a canon li-ion battery e160814 and the other is Rebel XS DS126191 with canon battery LP-ES. They both are about 6+ years old.
Expert:  Freddy M. replied 1 year ago.
.
Are the batteries that old as well?
.
Customer: replied 1 year ago.
The problem just started last month and I bought replacement batteries two weeks ago.
Expert:  Freddy M. replied 1 year ago.
.
Ok have you cleaned the contacts in the cameras? What are you using to charge them?
.
Customer: replied 1 year ago.
I am using the canon chargers that came with the cameras, and I have not cleaned the contacts.
Expert:  Freddy M. replied 1 year ago.
.
Ok please try cleaning the battery contacts in the cameras and then test them again. You can use either alcohol or a tiny bit of warm water on a cotton swab. It is odd for two chargers to fail at the same time but it is possible they are the cause, have you tried switching them to a different outlet? Not due to the outlet just as a test.
.
Customer: replied 1 year ago.
I have tried several outlets, and the chargers have worked as expected. I will try cleaning the contacts.
Expert:  Freddy M. replied 1 year ago.
.
They have been working but unless you try another one, it is impossible to know if they are working properly. Hopefully the cleaning will help, let me know what happens.
.
Customer: replied 1 year ago.
That hasn't helped so far, but I will try recharging the batteries and cleaning the contacts again later. Thanks.
Expert:  Freddy M. replied 1 year ago.
.
Ok when you can let me know the results, you can get back to me any time by going to justanswer.com and clicking on my questions at the top.
.

Related Camera and Video Questions