How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Russell A. Your Own Question

Russell A.
Russell A., Camera and Video Technician
Category: Camera and Video
Satisfied Customers: 6003
Experience:  30 years of experience as a TV station technician gives me a unique understanding of technical equipment issues.
24675295
Type Your Camera and Video Question Here...
Russell A. is online now
A new question is answered every 9 seconds

I have a Nikon d5300. The problem I have is that when i put

Customer Question

I have a Nikon d5300. The problem I have is that when i put a fully charged battery (I put it on my tongue and got a slight charge), close the door and then turn the camera switch "on", the little green button to the left of the "trash" flashes green for 1 to 2 seconds and then goes off.
The camera has not power.
The battery I'm using is new... I received it 6-19 and I fully charged it.
Any thoughts?
Thank you,
Paul
Submitted: 1 year ago.
Category: Camera and Video
Expert:  Russell A. replied 1 year ago.
Hi, Have you tried powering the camera on with the memory card removed? If not, please do so and let me know the result.
Expert:  Russell A. replied 1 year ago.
Hi, Have you tried powering the camera on with the memory card removed? If not, please do so and let me know the result.
Customer: replied 1 year ago.
I took the card out and then closed the door. Turned the camera switch to "on".When I did that, the green light to the lower left of the "trash" Did not turn on at all.
Customer: replied 1 year ago.
I then put the card back in the slot, closed the door and turned the switch "on". The green light to the lower left of the "trash" turned on for 1 to 2 seconds and then turned off.
Expert:  Russell A. replied 1 year ago.
Did the LCD screen illuminate when you powered on without the memory card?
Customer: replied 1 year ago.
Nothing happened. It was as if the camera was dead.
Expert:  Russell A. replied 1 year ago.
The last time that the camera functioned properly, do you remember the last function preformed be for it failed. Taking a shot? Downloading photos? Camera off? etc..
Customer: replied 1 year ago.
Good question... The last thing I did was download a picture wirelessly through the wifi (see attached image).
Expert:  Russell A. replied 1 year ago.
Try a hard reset. remove the lens, memory card and battery, set the mode dial to M (manual), and switch the camera to the ON position. Allow the camera to sit idle for 30 minutes. Then, switch the camera to OFF, re install the battery, memory card and lens, switch it on and try to fire the shutter while still in M (manual) mode. Please let me know the result.
If you require additional information, please use the Reply to Expert Tab to contact me. Click the ratings only after our exchange is complete and you are satisfied.
If you are satisfied that my answer is accurate, please do not forget to rate my answer OK, Good or Excellent.
Thank you
Customer: replied 1 year ago.
Will do and will let you know the results.
Expert:  Russell A. replied 1 year ago.
Thanks for the update
Expert:  Russell A. replied 1 year ago.
If you require additional information, please use the Reply to Expert Tab to contact me. Click the ratings only after our exchange is complete and you are satisfied.
If you are satisfied that my answer is accurate, please do not forget to rate my answer OK, Good or Excellent.
Thank you