How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Brian Your Own Question
Brian
Brian, Plumber
Category: UK Plumbing
Satisfied Customers: 821
Experience:  16 yrs. experience as plumber, including full bathroom and kitchen installations.
63187465
Type Your UK Plumbing Question Here...
Brian is online now
A new question is answered every 9 seconds

I am lee , i have a greenstar 30cdi i think , combined with

Customer Question

hi i am lee , i have a greenstar 30cdi i think , combined with a mega flow , i have cleaned everything out that i should but do not seem to be getting a spark to ignite the gas, i have cleaned the probe / spark plug bits also but no spark ?
Submitted: 1 year ago.
Category: UK Plumbing
Customer: replied 1 year ago.
is someone going to get back to me or do i need to do something else ?
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 1 year ago.
some additional info..the error message is EA i have cleaned out the condensate vessel and the pipe is clear, when the boiler starts up the fan starts, gas is present at the gas valve and then the ignition clicks away but you can see through the little window that their is no actual spark... i have somebody coming out but they cant do anything before monday, i dont need the heating of course but the water is an issue with a young family, so if anyone has any ideas that would be much appreciated. thanks Lee
Expert:  Brian replied 1 year ago.
Hi, my name is***** have been in the plumbing & heating trade for approximately 15 years. I will be helping you today.
if you get the EA fault, the condensate trap, or siphon is not blocked. If clear check the ionisation current which tells if the flame probe is working. Go to service mode 1 (press and hold the spanner button) then turn the radiator heat control until the display reads 3.3. After a few seconds the display changes. If it reads 2 or 3 it is working, 0 or 1 and it needs cleaning, or replacing" if it needs replacing you wont be able to do anything before monday anyway unfortunately
Customer: replied 1 year ago.
Hi Brian thanks for that, when i hold the spanner button down for about 5-10 seconds the dial does not appear to do anything so i cant adjust to 3.3 however when i then release the spanner button the screen changes from EA to 1.A is this what we are looking for ?
Expert:  Brian replied 1 year ago.
yes that should be the engineers menu now turn the heat control and the menu should change
Customer: replied 1 year ago.
no the heat control does not change anything it just stays on 1.A
Expert:  Brian replied 1 year ago.
Ok I will opt out to see if anyone else can help you further
here is a link to the service booklet. I see it s the eco button that takes you up through the menu. sorry my mistake.
but have a read it may help.
https://www.worcester-bosch.co.uk/cache/file/1/greenstar-cdi-service-booklet-for-engineers.pdf

Related UK Plumbing Questions