How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask green-owl Your Own Question
green-owl
green-owl, Engineer
Category: UK Electronics
Satisfied Customers: 74
Experience:  16 years, include works in aluminium plant, industrial machinery, military weapons, programming
14666028
Type Your UK Electronics Question Here...
green-owl is online now
A new question is answered every 9 seconds

There seems to be an issue with my pioneer media box pdp

Customer Question

There seems to be an issue with my pioneer media box pdp r04e. No longer any picture on my screen I think the hdmi port on the box is broken. HDMI cable won't stay in place. How do I replace the media box? Does it have to be the same model?
Submitted: 12 months ago.
Category: UK Electronics
Expert:  Aric replied 12 months ago.

Hello, before we go thinking the box is the problem- I need more info.

1) What's the model number off the PDP (display panel)?

2) What exactly shows on the screen when you turn the set on (Please Wait.....etc.)?

3) Are there any blinking lights on the front of the media receiver, or the display panel?

Customer: replied 12 months ago.
Hi
1) PDP 434PE
2) no message to screen is blank
3) no both are green
Expert:  Aric replied 12 months ago.

If there's no message to screen- then this has nothing to do with the HDMI port being broken. The welcome screen supersedes all your external connections. Sounds like you have a much deeper problem.

Please try a hard reset and let me know exactly what happens.

1) Unplug both the MR (receiver) and PDP (panel) from power.

2) Carefully disconnect then reconnect the two system cables on BOTH ends, making sure they are secure.

3) Plug both the MR and PDP back in and press power.

4) Let me know EXACTLY what the lights on each do and if ANYTHING AT ALL displays on the TV screen.

Customer: replied 12 months ago.
Done all of that. Still nothing on the screen. Both lights still green.
Sorry maybe I should have added that my media box is connected to my SKY HD box. This has been the case for 4 years +
Expert:  Aric replied 12 months ago.

If nothing at all displays on the screen then this means there's a hardware failure with your screen. If the issue was elsewhere, you would at least get the Pioneer welcome screen when you turned it on. So are you saying you do not get that at all?

Customer: replied 12 months ago.
When I switch to another input i just get the 'snow' you used to see on TVs when no ariel connected
Expert:  Aric replied 12 months ago.

None of this lines up. I'm going to opt out and allow another expert to help.