How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, European Car Expert
Category: UK Car
Satisfied Customers: 398
Experience:  ASE & Bosch Certified Master Tech. Over 30 years experience.
13230946
Type Your UK Car Question Here...
Marty is online now
A new question is answered every 9 seconds

I have a Suzuki Wagon R+, 2002, 1.3l, and it has ""

Customer Question

Hi, I have a Suzuki Wagon R+, 2002, 1.3l, and it has "blown" something. I didn't let it run for more than a few minutes (just to get it to a safe place) but it did still have power to drive, albeit with much misfiring/popping back. From inside it sounded like it could be manifold/head etc., but on inspection it is literally blowing right by the off side ignition coil pack, such that it has deposited a light brown dusty film over it, with no other obvious damage/fault. Any ideas, please?
JA: Where exactly do you think the noise is coming from? And how long has this been going on?
Customer: See above - it only ran for a few minutes, and it;s by the offside coil pack
JA: What is the model of your '02 Suzuki?
Customer: As above - Wagon R+
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: Nothing attempted yet, it's parked up near where it went wrong and whether I attempt it depends on the diagnosis
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 3 months ago.
Category: UK Car
Expert:  Tim Mohr replied 3 months ago.

Hi, my name is ***** ***** the color of the residue like a rusty color?

Related UK Car Questions