How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 25765
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2006 W211 E320 CDI with Webasto TVS900 sunroof. It

Customer Question

Hi good day,
JA: OK. To minimize me, please click the down arrow at the top right corner of this box.
Customer: I have a 2006 W211 E320 CDI with Webasto TVS900 sunroof. It worked 100% the previous day and the next day no sound, no movement nothing.
JA: Are you fixing your E320 Cdi yourself? What have you tried so far?
Customer: I checked fuse 9 in trunk and it is 100%
JA: Most vehicles have two fuse panels. Have you located both?
Customer: Yes I also checked the one at the driver door. 5 A and think it was fuse 4.
JA: Anything else you want the mechanic to know before I connect you?
Customer: It feels like the sunroof do not get power at all. where do I test for power except for the fuses?
Submitted: 3 months ago.
Category: UK Car
Customer: replied 3 months ago.
No responce yet?
Customer: replied 3 months ago.
I have received your mail indicating that this is a UK manufactured vehicle. However I believe that all wiring and especially the sunroof is the same as the ones from America. I frequently browse the internet for answers and yes all these E class Mercs are the same. Only driver seat which is on the right hand side and not left side. The sunroof is Webasto Hollandia TVS 900 which is a US manufactured unit operating in various cars and suv's. I need to know does this type of sunroof have a method to reset its actuator motors or control unit?
How do I test the 5 function switch to make sure it is not faulty?
Where do I test that the sunroof receive power to the motor and or control unit?If you cant assist pls assist me in getting a refund on the moneys paid.
Expert:  Pete replied 3 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

The control unit for the sun roof is usually the over head control unit that the switch is located in.This control unit can fail internally electronically and cause this issue here needing replaced.If you have not had the fault codes checked/read out to see what codes are set this needs done.If any codes are set the codes will need diagnosed to help locate and repair this fault here.If you can access the sun roof motor you might try tapping on it to see if it operates from there.If it does then the motor needs replaced.If it does not then further testing is needed to locate and pinpoint this fault.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 3 months ago.
Pete,
Fault codes have been checked with diagnostic. There are no fault codes stored. I need to know how I can reach the control module. Do I need to remove the front interior light assembly? I want to test if power is getting to the control unit and or motor.
I just do not know how to get in there without damaging anything. Remember this is a Holloandia TVS 900 and it is in closed position. I can remove the 5 function switch. It looks like this is feeding back to the control module. Very thin wiring therefor I believe it is low voltage. Can you indicate what voltage I need to get on which point when I unplug the plug going to the switch?
Expert:  Pete replied 3 months ago.

Unfortunately my info is not showing how this is removed or the diagrams to test this here.If you would like I can open your question up for others here to see if anyone else can assist further just let me know if this is something you would like to do.

Thanks Pete

Customer: replied 3 months ago.
have you received any other info from other persons on this sunroof problem?
Expert:  Pete replied 3 months ago.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete