How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, European Car Expert
Category: UK Car
Satisfied Customers: 395
Experience:  ASE & Bosch Certified Master Tech. Over 30 years experience.
13230946
Type Your UK Car Question Here...
Marty is online now
A new question is answered every 9 seconds

2013 Ford Ranger 2.2 tdci. Vin no AFANXXMJ2NCD52966 Eng no

Customer Question

2013 Ford Ranger 2.2 tdci.
Vin no AFANXXMJ2NCD52966
Eng no P72K
Need the correct adjustment for crankshaft sensor. Can be adjusted deeper.
I am not geeting the correct waveform on the oscilloscope (magnetic).
Submitted: 1 month ago.
Category: UK Car
Customer: replied 1 month ago.
Eng code from Autodat GBVAJPF.
Expert:  Greg replied 1 month ago.

Hi, I'm Greg (Indy-Tech).
Welcome to JustAnswer. I'm reviewing your question now, and will post back with your reply ASAP.
Rgds Greg.

Customer: replied 1 month ago.
For magnetic sensors should be 0.45mm gap? Just a bit difficult to adjust with everything assembled.
Expert:  Greg replied 1 month ago.

Is this a new sensor you are fitting, as we use the old sensor as a gauge to find the cap as you can see where the original was fitted due to the marks .

This makes it easier to fit .

Greg

Customer: replied 1 month ago.
The vehicle was towed into my workshop for not starting. Engine was overhauled. Sensor that was fitted is damaged becuase it was fitted too deep. They brought another sensor and I fitted it more or less OK but the signal on my oscilloscope is not good.
The other workshop tell me this sensor that I want to fit was taken off another Ranger that is starting.
Expert:  Greg replied 1 month ago.

Is the ranger now starting ?

If the sensor is pushed in as far as it will go then pulled back off 1mm it should start if the sensor is good

can you post me a copy of your waveform .

Greg

Customer: replied 1 month ago.
file:///C:/Users/willie/Documents/Ranger%20scan%201.jpg
I can set up my scope any way I want but the crank sensor signal stays like that. I also scoped another Ranger and I get the same signal from the crank sensor. At least I can see the timing is out.
Customer: replied 1 month ago.
The Ranger 2 scan is from a running Ranger.
Expert:  Greg replied 1 month ago.

How is the engine running ,check engine light ON ? Any malfunction codes .

Greg

Customer: replied 1 month ago.
Morning. I asked the people who brought the Ranger to me to turn the flywheel by 180 degr. It starts with no fault codes logged and no eng light on. The only thing that puzzles me is the crank sensor signal? 1st Ranger 1 scope was for the non starting. 2nd Ranger 2 scope was on the Ranger thar was running.
Expert:  Greg replied 1 month ago.

Morning Willie .

The two are very identical . looks to me like bad teeth on the flywheel .

But if was out of spec it would flag a code .

Greg

Related UK Car Questions