How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24170
Experience:  Over 17 years experience diagnosing and repairing automobiles.
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

In my s-max, 2006, 1.8 TDCi, radiator fan runs on a cold

Customer Question

JA: Hello. How can we help?
Customer: hello,
in my s-max, 2006, 1.8 TDCi, radiator fan runs on a cold engine, with the air conditioning errors in the ecu.A / C sometimes switches off eg when the engine enters the high rpm, and no longer turn on.high pressure sensor shows the state off.
Do you have any idea what to check?
JA: Has the car been overheating? Have you checked the fuses?
Customer: No, the car is not overheating....
I checked the fuses.... but...
which fuse can cause a problem?
JA: What is the model of your '06 Ford?
Customer: s-max 1.8 TDCI engine
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: my mechanic does not know what might be the problem. So I repair itself.
I read DTC, checked in forscan engine temperature / coolant checked the fuses, cleaned several connectors...
I swapped control module fan... fromother car.
JA: Anything else you want the mechanic to know before I connect you?
Customer: I have no idea what might still control the fan. and why if something is wrong there is no error.
Submitted: 1 month ago.
Category: UK Car
Customer: replied 1 month ago.
hello, I understand that you can not help me?any specific hints for my problem?
Expert:  Pete replied 1 month ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

I would have all ac pressure and temp sensor signals checked for any issues.If one of these sensors is sending a false signal possibly this can cause this type of fault here and would need replaced.If this is or was already checked and found o.k. let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related UK Car Questions