How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24729
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2002 vito 112 CDi it has gone into limp home mode

Customer Question

I have a 2002 vito 112 CDi it has gone into limp home mode and wont rev beyond 2500 RPM my mate has put his snap on code reader onto it and the famous P1470 code has come up with the explanation Charge Pressure control. where is this unit situated on the van and do you think replacing this will cure my problem, or in your experience is it likely to be something else.
JA: Just to clarify, what's the exact code? And have you tried to reset it?
Customer: The code is P 1470 the text says charge pressure control. We have tried a reset but the problem comes back very quickly with the same code.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: yes hoping to fix it myself. the only thing I have done so far is a very brief check of the vacuum pipes etc.
JA: Anything else you think the mechanic should know?
Customer: van has done 120000 miles. having checked on the web sites this seems to be a common problem, just need to fix it as soon as possible as I need the van to get to and from work.
Submitted: 4 months ago.
Category: UK Car
Expert:  Pete replied 3 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

This fault here may be due to an issue with the turbo itself or one of the turbo components like a boost pressure sensor as this can be common for this issue here.The turbo and turbo components need checked to locate which is the cause here then the affected component replaced.This may require special test equipment for testing from a dealer or repair center on this model.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related UK Car Questions