How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask C. Walker, Jr. Your Own Question
C. Walker, Jr.
C. Walker, Jr., Auto Mechanic
Category: UK Car
Satisfied Customers: 709
Experience:  Shop training and experience.
Type Your UK Car Question Here...
C. Walker, Jr. is online now
A new question is answered every 9 seconds

I hace a 2005 vito had the ASR ESP light come on : Replaced

Customer Question

I hace a 2005 vito had the ASR ESP light come on
JA: Do you know the code? When was the last time you had new tires mounted?
Customer: Replaced the brake switch attached to brake Mercedes part van seems to be very unstable on the road now suspension corning differently I have driven this van for over 120,000 miles so know the van inside out the ASR/AAS/BAS light was originally on 9looks like flat tyre
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: second hand tyres put on 3 months ago
JA: Anything else you think the mechanic should know?
Customer: no
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mercedes Mechanic about your situation and then connect you two.
Submitted: 4 months ago.
Category: UK Car
Expert:  C. Walker, Jr. replied 4 months ago.

Good afternoon, I am here to help. Most of the times when this occurs it is caused from a bad ABS wheel speed sensor. What you will want to do is check each sensor for any dirt. I would recommend removing the sensor from each of the wheels clean the sensor using some brake parts cleaner. Check the wiring for any cracks or indication of damage or pinching. If all looks good and still the issue is present you will need to test each sensor. You can do this with a DVOM on AC voltage. You will connect the power and ground up either way to the two wires, spin the wheel ensuring the sensor is giving out a good reading. The one that is not giving out a reading you need to replace to correct the problem.

Related UK Car Questions