How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24208
Experience:  Over 17 years experience diagnosing and repairing automobiles.
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I'm George Hoey Renault master 2.5 dci120 fitted new pistons

Customer Question

Hi I'm George Hoey Renault master 2.5 dci120 fitted new pistons and rings had some work done on the head refuted engine and it would not start plunged out cam shaft sensor and of it wen driving perfect plug sensor won't start didn't have any timing gear off or high pressure pump off just timing belt any ideas ????
JA: Figuring out why a car won't start can be a challenge - it could be a simple repair, or something a bit more complicated. Fortunately, the mechanic I'm going to connect you with knows all the tricks and shortcuts. Are you hoping to fix this yourself?
Customer: Yes I run a garage and I also wend to main dealer they recon it's timing
JA: Great! What have you tried so far?
Customer: New cam sensor
JA: Is there anything else the Renault Mechanic should be aware of about your Renault?
Customer: A code 488h/1160 keeps coming up
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Renault Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: UK Car
Expert:  Pete replied 5 months ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know. This does sound like a fault with one of the timing components being off here since it does run with the cam sensor unplugged but not plugged in.I would have the mechanical timing components checked to see if timing is out of alignment or if a timing component is found damaged in any way needing repaired or replaced.I would also check over the engine for any components left disconnected or damaged needing repaired or replaced as well.If these are all checked and found to be o.k. let me know. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete

Related UK Car Questions