How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: UK Car
Satisfied Customers: 21596
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your UK Car Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Trouble with cluster on 2004 Chrysler pt cruiser JA: Sometimes

Customer Question

Trouble with cluster on 2004 Chrysler pt cruiser
JA: Sometimes things that you think will be really complicated end up being easy to fix with Chrysler. The Chrysler Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so he can help you best.
Customer: Car has been stood for a while, cluster does not work and also interior lights. Fitted new battery but still a problem.
JA: Are you hoping to fix this yourself?
Customer: Yes
JA: Great! What have you tried so far?
Customer: Fuse, lamps, charged battery, shorted battery leads together, disconnected battery for 5 minutes.
JA: Is there anything else important you think the Chrysler Mechanic should know about your Chrysler?
Customer: No
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Chrysler Mechanic about your situation and then connect you two.
Submitted: 6 months ago.
Category: UK Car
Expert:  sprinkles08 replied 6 months ago.
Hello and welcome to JustAnswer!You have a couple different issues going on. You may have a wiring or ignition switch issue causing the instrument cluster problem or it could be an internal cluster issue. The interior lights could be wiring, bulbs, or possibly the switch.There is no response from the instrument cluster at all, it is just as if the key is off?Have you checked the dimmer to make sure the interior lights haven't been turned off?
Customer: replied 6 months ago.
Hello,The boot hatch and fog light indicators on the cluster illuminate but nothing else. using the left hand stalk to operate the lights doesnt work either.Bulbs all good in the dome and the boot area.
Expert:  sprinkles08 replied 6 months ago.
Does the radio work?Do the power locks work?
Customer: replied 6 months ago.
yes an yes
Expert:  sprinkles08 replied 6 months ago.
Have the instrument cluster power and ground feeds been tested?
Customer: replied 6 months ago.
Yes, there is 13+V at the supply pin to the cluster when the engine is running, vehicle chassis used for ground. I have not specifically checked for the resisitance to ground but as the rest of the vehicle electrics work do you thinkt his would be an issues.?We have had the cluster out and looked over the PCB, no visible hot spots or burns. All contacts and board have been cleaned with suitable cleaning agent.
Expert:  sprinkles08 replied 6 months ago.
Only one wire to the cluster has power with the key on?