How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24723
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I'm havin trouble with my nissan kubistar starting when

Customer Question

Hi I'm havin trouble with my nissan kubistar starting when engine is cold I've changed glow plugs I have power to plugs and still won't start there is a metal realy bolted next to the battery which I think is for the glow plugs and is not clicking when ignition is turned on van starts fin with a shif of easy start thanks for any info possible Marty
JA: Figuring out why a car won't start can be a challenge - it could be a simple repair, or something a bit more complicated. Fortunately, the mechanic I'm going to connect you with knows all the tricks and shortcuts. Are you hoping to fix this yourself?
Customer: Yes please
JA: Great! What have you tried so far?
Customer: New glow plugs old ones where faulty checked the wires to plugs have power not sure if they getting a Earth though
JA: Is there anything else the Nissan Mechanic should be aware of about your Nissan?
Customer: One glow plug wouldn't come out so had to leave it in or I would of changed all 4 of them but changed other 3
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Nissan Mechanic about your situation and then connect you two.
Submitted: 7 months ago.
Category: UK Car
Expert:  Pete replied 7 months ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know. Usually the glow plugs receive ground from the engine threads they are mounted into.It sounds like this is a lack of fuel since you can use easy start and it starts.I would have the fuel system tested to see if this is a fault with a lack of fuel due to issues with a restricted fuel filter,fuel injection pump or injectors leaking as these are the most common causes here.If this is or has been checked and found o.k. let me know. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete