How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Edward Your Own Question
Edward
Edward, Service Technician
Category: UK Car
Satisfied Customers: 2768
Experience:  20 + years experience on various makes and models.
29534642
Type Your UK Car Question Here...
Edward is online now
A new question is answered every 9 seconds

I have a 92 ford thunderbird 3.8 non supercharged v6 the

Customer Question

I have a 92 ford thunderbird 3.8 non supercharged v6 the fuel pump runs continuous have spark and fuel pressure but no injector pulse when this happens no start sometimes the pump will run and shut off when that happens it starts right up
Submitted: 8 months ago.
Category: UK Car
Customer: replied 8 months ago.
There was no option for ford when selecting vehicle so I had to select uk ford but it is us ford
Customer: replied 8 months ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Juan Crespo replied 8 months ago.
Hi there.Both fuel pump and injector pulse are controlled by the onboard computer (ECA). In this case, the fuel pump relay (FPR) might be faulty and back-feeding the ECA, thus causing it to act up.A few simple electrical test results should tell us what we need to know. Do you have and know how to use a good ohm/voltmeter?
Customer: replied 8 months ago.
Yes I checked the eec relay and it has power and ground
Customer: replied 8 months ago.
Are you there
Expert:  Juan Crespo replied 8 months ago.
Oh yes, I am. Problem is this is not a typical chat, there is a pause between the time you post something and when I get to see it on my screen. It also takes a little time to look up and upload the material we'll need to resolve your issue. Is that OK?
Customer: replied 8 months ago.
I pretty sure the fuel pump relay is labeled as the eec relay next to the battery I have tried replacing cause I had power and ground to it and that relay would click when the pump would prime sometimes also I heard the the computers were an issue so I have replaced that with a reman a1 card one but no luck
Expert:  Juan Crespo replied 8 months ago.
The fuel pump relay is in the trunk (see attached graphic). Set your voltmeter to 20V DC. Unplug the FPR and place the voltmeter's Red probe on the now empty relay socket cavity 2; place the Black probe on empty cavity 1, then have a helper crank the engine for a couple of seconds and turn the ignition off:Did the voltmeter show battery voltage while the engine was cranking?Did the voltmeter show voltage after the ignition had been switched off?
Expert:  Juan Crespo replied 8 months ago.
Here is that graphic.
Customer: replied 8 months ago.
Ok so to double check I'm just checking for power at the relay socket when key is at run and start position
Expert:  Juan Crespo replied 8 months ago.
No. By placing the voltmeter probes as I indicated you're checking not only for power from the Inertia switch, but for ground from the ECA.The next test would be to get a jumper from battery positive to connect to the Red probe while leaving the Black probe on cavity 1. If there is still voltage showing after the ignition is switched off, then the ECA is bad. If there is no voltage, then the fuel pump relay (FPR) is bad.If you'd like, I could upload that part of the electrical diagram so you could follow along.Best Regards
Customer: replied 8 months ago.
Yes that would help out a lot
Expert:  Juan Crespo replied 8 months ago.
Not a problem. Just give me a couple of minutes to get it ready...
Expert:  Juan Crespo replied 8 months ago.
OK. Here it is. Please let me know when you get it as well well as the results of the tests I indicated.
Customer: replied 8 months ago.
So I have voltage with key on and while cranking pump always runs no start with key off no power I swapped a relay with a new on that I had from the eec relay look exactly the same no luck still the same issue
Expert:  Juan Crespo replied 8 months ago.
I'm sorry, but I can only help you if you follow my instructions. As such, I don’t have any other information that could help you at this time. I’ll opt out so others may try. Please do not reply until another expert responds or the site will cycle this request back to me.Best Regards.
Expert:  Edward replied 8 months ago.
Hello, Eddie here and I will do my best to help since the previous tech opted out. If you have spark and fuel pressure, and no injector pulse, then likely the PCM is bad, (Powertrain Control Module) Also, the fuel pump running continuously with the key ON, is another indication of the PCM failing because the PCM is only supposed to ground the fuel pump relay for two seconds when you turn the key on, the pump is suppose to cycle just for two seconds, then shut off, the pump should run all the time when cranking. Do you have 12 volts to the injector with the key ON? when it acts up?
Customer: replied 8 months ago.
Yes I do have 12 volts to the injector when not starting just no pulse but I replaced the Pcm with a reman from a1 cardone it worked the first day and then same issue so not sure if Pcm was the issue or do u think it's possible I got a dud
Expert:  Edward replied 8 months ago.
So another PCM fixed it for a day? then no injector pulse again?
Customer: replied 8 months ago.
Yes but I only drove it twice that day
Expert:  Edward replied 8 months ago.
I know I got a dud A1 cardone mass air flow sensor about two weeks ago. but, hard to say for sure.
Expert:  Edward replied 8 months ago.
You don't have your old PCM by chance do you?
Customer: replied 8 months ago.
But it's still works and doesent sometimes it's random pretty much the worst kind of issue
Customer: replied 8 months ago.
Yes I do
Expert:  Edward replied 8 months ago.
You tried to put it in there and see if injector pulse came back ?
Customer: replied 8 months ago.
Yao I swapped them same thing so I put the new computer back in next day started
Expert:  Edward replied 8 months ago.
Can you get that A1 warrantied? I would really like to try another one, because you have spark, so the PCM is seeing spark through the spout circuit. I don't know what else it could be besides the PCM unless you have an internmittent wiring issue. and that pump running all the time is another sign of failing PCM.
Customer: replied 8 months ago.
I'm gonna try and c I think so
Expert:  Edward replied 8 months ago.
If you can get it warrantied, I would. I believe that is whats going on, unless there is some weird wiring problem between the injectors and the pcm.