How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: UK Car
Satisfied Customers: 21799
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your UK Car Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I'm at my wits end with my Jeep Commander, its a 3.0 V6 Diesel

Customer Question

I'm at my wits end with my Jeep Commander, its a 3.0 V6 Diesel and the transmission keeps dropping into Limp mode i.e. 3rd gear. I took it to my local Jeep specialist and he has replaced the valve block and electrics pack at a cost of £2000, it worked Ok for a couple of weks then recently while driving it dropped out of gear intoi neutral banged a few times and then back into limp mode. Back to the garage and he said it was the gear shift, £300 later I brought it home and on the way back, its in limp mode again..... any ideas?
JA: Thanks. Can you give me any more details about your issue?
Customer: Like what, I think I just gave you everything
JA: OK got it. Last thing — Jeep Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 9 months ago.
Category: UK Car
Expert:  sprinkles08 replied 9 months ago.
Hello and welcome to JustAnswer!If the valve body and electronic shifter module have been replaced and it is still going into limp in then possible remaining causes woudl be an internal transmission issue, wiring, the transmission control module, or a loss of power or ground to the TCM.Do you know what fault codes are currently setting in the ECM and TCM?
Customer: replied 9 months ago.
That's one of the problems, there are no fault codes that are appearing when the car is plugged into the computer. (The technician is using a Chrysler computer). He said that when he changed the valve block and electric pack the gear box looked OK there was no sludge, filings etc. in the sump.
Expert:  sprinkles08 replied 9 months ago.
The reason the transmission goes into limp in is because fault codes set, if it's going into limp in there is no question codes are setting.Can you describe exactly what you're feeling?
Customer: replied 9 months ago.
The trouble started about 5 months ago, I went on holiday and just the way the dates worked the car was left for 4 weeks before being driven. The car then started fine and I drove for about 2 or three miles when there was a 'clunk' form the gear box and the car went into limp mode i.e. 3rd gear and will not go any faster than around 30mph. I took it to my local independent Jeep specialist and he serviced the car and replaced the transmission fluid. The car has only done 62000 miles and he said that looking at the seal on the transmission fluid, this was the first time it had been changed. I took the car home and after a day or so it went back to limp mode in the same fashion. I retuned it to him and he said then it must be the valve pack, I had a limited warrenty on the car and after a period of time arguing with them they admitted the claim and paid the max amount (£1000) I still had to find the remaining. Anyway I collected the car and everything was fine for around 3 weeks, in which time I had towed a horse trailer on a couple of occasions all without issue. Then one day on my way to the shops the car (with a bit of a bang) while driving went into neutral. I stopped the car slipped in an out of Drive and set off again, it did the same. Stopped once more and reset the car went into limp mode and I drove straight to the garage. They then diagnosed a faulty gear shift, that was duly changed and I picked the car up on Saturday, I got maybe 2 miles from the garage and it went back into limp mode. I'm now pulling my hair out and reluctant to throw more money at the car until I can get a definitive answer of the most likely cause of the issues. So there you have the whole sorry tale.
Expert:  sprinkles08 replied 9 months ago.
The engine light is coming on, correct?
Customer: replied 9 months ago.
Nope, no warning lights at all.
Expert:  sprinkles08 replied 9 months ago.
Do you have the part numbers of all parts replaced?

Related UK Car Questions