How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24141
Experience:  Over 17 years experience diagnosing and repairing automobiles.
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Have taken egr off merc vito 111cdi 2008 cleaned and seems

Customer Question

hi have taken egr off merc vito 111cdi 2008 cleaned and seems to be working ok but when drive for about 50mile loose pressue and cant hear the turbo stop for a few mins start up full power again some times eng man light will come on with code p0402 clear the code and it fine again
Submitted: 7 months ago.
Category: UK Car
Expert:  Eric replied 7 months ago.


I am sorry that you have not been helped yet. I just came online and saw your question.

Based upon the symptoms and how soon they appear, the egr valve needs to be replaced at this point

Expert:  Eric replied 7 months ago.

If you have any other questions on this, feel free to ask for more help by clicking the REPLY TO EXPERT button, otherwise please click the OK SERVICE, GOOD SERVICE OR EXCELLENT SERVICE to pay for services rendered per your customer agreement as this is a PAYSITE and experts are not paid for their time, services, or knowledge until you do so.Thank you.

Please note that continued poor accept rate now leads to experts ignoring future questions you may post as they realize that they will not be paid for their time or services. Thank you

Customer: replied 7 months ago.
Got a new egr coming tomorrow will let you know thanks Steve
Expert:  Eric replied 7 months ago.


ok, sounds good

Customer: replied 7 months ago.
hi Eric fitted new EGR valve yesterday £160 drove for about 40 miles still the same prob looses power looks like not the egr ,stop for a few mins start up and runs fine again. when running fine can hear the turbo but not when it looses power
Expert:  Eric replied 7 months ago.


and no other codes besides the P0402?

Customer: replied 7 months ago.
no other codes . its like there is some kind of build up of pressure and when i turn off for a few mins it releases
Expert:  Eric replied 7 months ago.


I will opt out at this point and see if another expert can help you

Expert:  Pete replied 7 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Have you checked to make sure the EGR ports on the engine are all cleaned of carbon?If not I would see if these can be cleaned to see if this corrects this fault here as this can sometimes occur and cause this issue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related UK Car Questions