How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24723
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I am currently attempting to retrofit a headlight washing

Customer Question

I am currently attempting to retrofit a headlight washing system to a 2012 x5 N55. This vehicle was purchased without the cold-weather packet, thus the washing system was not pre-installed. We have purchased all original pumps, jets, hoses etc, and the entire system is installed. I have also recoded the JBBF (Junction Box Controller) to ensure that the SRA is activated.
Unfortunately we are not able to locate the power supply for the washing system pump. Based on all documentation I've been able to find, there is only one version of the cable harness for the washing systems, at it includes a plug for the headlight washer pump. The part number for this harness is *********** and I've not been able to find any alternatives to this for any model year of the e70.
I would like to know if there is in fact an alternative cable harness out there without the connector for the headlight washer? If so, what is the part number. If we really do have a harness which is missing the connector, I'd like to know what pins we need to populate on the Junction Box in order to supply power to the headlight washer pumps.
Many thanks.
Submitted: 9 months ago.
Category: UK Car
Expert:  Pete replied 9 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

I see no one has posted any info on this here.In some cases this can be due to the info being difficult to obtain or the correct person that may have this info may not be online.If your model did not come with this harness or connection equipped to it then you may have to see if you can locate it from a dealer as a retro fit kit or harness or see if you can obtain it from a salvage yard possibly.I dont show the diagrams on this here to post how to wire this myself.If you still want to try and wire this yourself if you cannot locate the harness let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 9 months ago.

Hi Pete,

In order to answer this question you will need access to the BMW WDS, and detailed knowledge of the e70. If you don't have both of these, I'd appreciate it if you'd withdraw your response. Your answer as it stands would not receive a positive rating from me.

Expert:  Pete replied 9 months ago.

I apologize for the delay.

Unfortunately I do not have what you need here.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete