How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Eric Your Own Question
Eric
Eric, Automotive Repair Shop Manager
Category: UK Car
Satisfied Customers: 29985
Experience:  Automotive Repair Shop Manager, Technician/JA Mentor
3195632
Type Your UK Car Question Here...
Eric is online now
A new question is answered every 9 seconds

I have a 2003 1.2l 16v emails Clio. It got very wet inside

Customer Question

Hi. I have a 2003 1.2l 16v emails Clio. It got very wet inside as it was laying up for a while and leaked through the sunroof. When I tried starting it the immobiliser light was flashing very fast and the engine didn't even attempt to turn. There was a clicking sound coming from behind the glove box. The key was locking and unlocking the car at that point. I took out the unit behind the glove box and disconnected the wires and dried it all with a hair drier and then put it all back together. The problem now is that it still won't start and the immobilise light doesn't come on at all. The key fob doesn't open or close the locks and the drivers electric window has stopped working. Any ideas?
Submitted: 10 months ago.
Category: UK Car
Expert:  Eric replied 10 months ago.

HI,

I am sorry that you have not been helped yet. I just came online and saw you question.

It is possible that there is internal corrosion/water damage to the control module. If you have a scan tool, we need to see if it communicates with the immobilizer control module and go from there