How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, European Car Expert
Category: UK Car
Satisfied Customers: 395
Experience:  ASE & Bosch Certified Master Tech. Over 30 years experience.
13230946
Type Your UK Car Question Here...
Marty is online now
A new question is answered every 9 seconds

I have Audi Allroad 2002 and I have problems with the Xenon

Customer Question

Hello.. I have Audi Allroad 2002 and I have problems with the Xenon headlights::
First the turning lights stopped blinking and left Xenon headlight did not ignite, just a little flash on startup. High beam on both front lights are ok.
Bought new hazard switch OEM (controls the blinking) and replaced both Xenon headligths bulbs (lower beam)
Sometimes both headlights are ON and ok – more often just the right headlight, and sometimes both are dead.. High beam on both sides functioning perfectly
It seems like a connection or wiring around the hazard switch is foulty – sometimes it´s enough to switch the car OFF – hold IN the hazard switch and switch the car ON again - and BOTH headligts turn ON – but does not work all the time…
Have you guy´s any experience with a problem like this ??
Submitted: 10 months ago.
Category: UK Car
Expert:  vwtech0405 replied 10 months ago.

Have you checked to see which trouble codes you have stored in the computer system for the headlamp module ??

Related UK Car Questions