How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24657
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I have just purchased a 2.8 pajaro, it was / is fine when

Customer Question

Customer: Hi, my name is ***** ***** have just purchased a 2.8 pajaro, it was / is fine when cold but when it gets up to Temp it starts mis behaving.
JA: Thanks. Can you give me any more details about your issue?
Customer: Sorry - yes i was abot to say, the engine man light comes on, the revs go up and down by themsleves, the rev counter drops totally off, it kicks blank loads of black smoke out. if stop engine and tinker for a while it starts up fine, no smoke no erratic reving etc
JA: OK got it. Last thing — Mitsubishi Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 10 months ago.
Category: UK Car
Expert:  Pete replied 10 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Since the check engine light has come on with this fault here the first thing that needs done is to have the fault codes read out with a scan tool or computer that will plug into your vehicle and can communicate with all computers.Once this is done any codes set need diagnosed to locate and repair this fault here.

I have seen issues with fuel injectors that will act up and cause this here as well as a fault with faulty exhaust sensors in some cases.The check engine light having the codes read out will help pinpoint the cause here for repair.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 10 months ago.
Pete, thanks for the response, after the car has stood a while and it is restarted the EML is extinguised, i have tried a code reader and it does not want to know, dont know if it is a protocol issue or simply age of vehicle, i am going to try a link wire to get code to flash on the EML. I am currrently leaning towars one of the temperature sensors as it a faul only when running hot. on cold start it fires without effort and runs no problem until hot. Can you tell me what temp sensors are on these, i have heard there is a injector temp sensor - is this correct.
Cliff
Expert:  Pete replied 10 months ago.

The one temp sensor that comes to mind that can cause this here is the engine coolant temp sensor.If this sensor is stuck reading that the engine coolant temp is cold all of the time this will occur here.I dont have the exact location of this sensor myself on your model here unfortunately.Most are located in the cylinder heads or the intake.This would be the sensor I would suspect causing this fault here needing replaced.

Let me know if you need anything else and feel free to rate my help here.

Thanks Pete

Customer: replied 10 months ago.
Thanks,one other thing i have noticed and have not checked it to see if it is normal for this model is the electric radiator fan runs continuosly, which i an surprised at, would expect to be from temp sensor especially as they also have a viscus fan.
Probably goes back to temp sensor fault, will see how i get on.
Expert:  Pete replied 10 months ago.

Your welcome.If the engine coolant temp sensor is sending a false signal this can cause all of the issues here and would need replaced.Let me know what you come up with here when your ready.

Thanks Pete

Related UK Car Questions