How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24729
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Ford galaxy no acceration on start up and bad power

Customer Question

Ford galaxy no acceration on start up and bad power
Submitted: 11 months ago.
Category: UK Car
Expert:  Pete replied 11 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

In allot of cases restricted exhaust can cause an issue like this here with the restricted exhaust component needing replaced to correct this fault.I have seen a plugged catalytic converter or resonator cause this as well as a restricted muffler.If you have not had the exhaust back pressure tested at all this needs done.If there is excessive back pressure in the exhaust the restricted exhaust component will need replaced to correct this fault here.If this was already checked and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 11 months ago.
Stil same with exhaust disconnected at Manifold
Expert:  Pete replied 11 months ago.

The only other issue I can see here that will cause a fault like this is low/weak fuel pressure or fuel volume due to a failing injection pump or restricted fuel filter needing replaced.I have also seen issues with debris in the fuel tank cause an issue like this here needing cleaned out to correct this fault.This will have to be checked into further possibly having the fuel system tested to see if any issues are found with the injection pump or possibly debris in the fuel tank needing corrected here.

Let me know if you need anything else and feel free to rate my help.

Thanks Pete

Customer: replied 11 months ago.
Stil no good, changed the injector pump and no good. And when starts hold throttle to floor and very slow to build up throttle, but when built up it will Rev after dat but, not as responsive as should be. Also when I go to take off it is like it is about to cut out,, any help very much appreciated
Expert:  Pete replied 11 months ago.

Have you had the fault codes checked at all to see what codes are set and if so what codes are set if you can post them here?

Let me know,thanks Pete.

Customer: replied 11 months ago.
No fault codes at al. Computer say no probs
Expert:  Pete replied 11 months ago.

If you can check the engine coolant temp sensor data and see if you have a faulty reading engine coolant temp sensor causing this issue here.I have seen faulty engine coolant temp sensors in the past before cause issues like this here needing replaced to correct this fault.

Check the throttle air inlet bore into the engine for any carbon build up and if any is found or any debris found in it this will need cleaned to correct this issue.

If this model uses a turbo at all there is a chance that the turbo itself is faulty.If the turbo has failed it will not create any boost pressure and causes this acceleration/power feel like you see here as well.

One last thing that will cause this is if your model uses a mass air flow sensor if this sensor is sending an incorrect signal of air flow to the computer this will cause a lack of fuel or over fuel issue and cause this issue here.I have had to replace several mass air flow sensors in the past before for issues like this here.

All of these need checked into to see if the fault can be located and repaired here.

Thanks Pete

Related UK Car Questions