How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: UK Car
Satisfied Customers: 20599
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your UK Car Question Here...
Matt is online now
A new question is answered every 9 seconds

2003 Mercedes deisol ML 270 will not start

Customer Question

2003 Mercedes deisol ML 270 will not start
Submitted: 11 months ago.
Category: UK Car
Expert:  Matt replied 11 months ago.

Hello

I'd check that you're getting full power to the glow-plugs, they pull a lot of current so take care when checking but see if the relay is clicking when the ignition is turned on first and also check the fuse if this is OK check to see if the engine earth strap is also OK.

You can test the glow-plugs with a multimeter by measuring the resistance across the plug ( between the power connection and the body) it should be around 4-8ohms if its tending to infinity / open circuit the plug is faulty or by using a clip on current clamp, either on the supply wire to glow plugs or onto engine earth, with glow plug light on you should see 15-20amps for each glow plug fitted, 4 cylinders would be approximately 60-80amps.

Also its worth checking that the electric pump that feeds the main fuel pump is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V

Also if its not injecting at all then check the connections to the crankshaft sensor, unplug it and check for corroded contacts and broken wiring, and consider fitting a new sensor - do the same for the cam position sensor

If the EGR valve is stuck open then this too can effect starting so try disconnecting it to see if this helps or changes anything

Could also be an injector leaking fuel back through the overspill pipe, so not getting enough fuel pressure to tell ECU to fire the injectors, this is trickier to find and you’ll need the garage to do a ‘run back’ test to identify which one is the issue

Lastly it’s also worth considering fitting a new fuel filter as if only slightly blocked this can lower fuel supply pressure and choke the main pump, the pump will be more sensitive to this when its cold as diesel thickens considerably with low temperatures.

Expert:  Matt replied 11 months ago.

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you