How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24729
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I replaced my c220 1997 mercedes throttlebody with a second

Customer Question

I replaced my c220 1997 mercedes throttlebody with a second hand one, cause I was told too by a mechanic who did the diagnosis with his computer I also changed my ovp relay but the car do not idle, please advise!
Submitted: 11 months ago.
Category: UK Car
Expert:  Pete replied 11 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.

If the throttle body has carbon build up in it the throttle body will need cleaned and can cause this fault here.The other issues I have seen cause this issue here is a fault with a vacuum leak on the engine itself with excess air entering the engine past a gasket like the intake gaskets leaking or a fault with a vacuum hose leaking.

This will cause a poor idle condition as well.If vacuum leaks have not been checked for this needs done and if a leak is found it will need repaired to correct this fault here.

These need checked into further to locate and repair the fault here.

Let me know if you need anything else and feel free to rate my help here.

Thanks Pete

Customer: replied 11 months ago.
Why would there be a vacuum problem if there was no vacuum problem before, I replaced the throttle body and it went fine but it started to over heat and then the idling problem started
Expert:  Pete replied 11 months ago.

Did the idle issue only occur after the throttle body was replaced and did the electronics come on the throttle body?

Customer: replied 11 months ago.
What I want to know is whether it is possible that I have a electronic problem , is there any relays or fuses perhaps that I can check, cause if I unplug the unit and keep my foot on the throttle it starts but don't idle
Expert:  Pete replied 11 months ago.

What can cause this issue here is a fault with the idle speed speed control actuator itself.If this issue only occurred after the throttle body was replaced and wasn't an issue until. It was replaced I suspect you installed a throttle body with a faulty idle speed actuator.

I don't see a specific idle relearn on this model here so this shouldn't be the cause here.

I don't see a relay or fuse in line that would cause this without causing any other issues as well.

Thanks Pete

Related UK Car Questions