How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: UK Car
Satisfied Customers: 20605
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your UK Car Question Here...
Matt is online now
A new question is answered every 9 seconds

I have a transit connect with fault code saying problems

Customer Question

i have a transit connect with fault code saying problems with egr and maf. It has low power on start up from cold and no excessive smoke
Submitted: 12 months ago.
Category: UK Car
Expert:  Matt replied 12 months ago.

Hello

Ok 1st thing to try is to check the connections to the EGR valve, if either the vacuum pipe of electrical connection are damaged / corroded then the EGR can be on all time which certainly will hurt performance. Its also possible that its a fault with the EGR valve so its worth removing the valve and cleaning it out with brakecleaner, if it looks particularly clogged then replace it.

If this is OK then check the small vacuum lines to the turbo and its connected control solenoid on the bulkhead, any cracks or leaks can give turbo issues and its best to have the boost pressure measured actually measured with a boost gauge to check that the turbo is healthy and that the sensor is reading correctly

If the above are all OK then try checking for airleaks after the airflow meter, any air dragged in here isn't 'seen' by the ECU and so not compensated for and leans the engine out causing rough running. As its a mechanical fault it tends not to turn on the fault light and you can sometime hear a 'hissing' noise with the engine running.

Check the hose clips for tightness and inspect the trunking for any cracks or splits and also all the vacuum system, the small bore pipes and fittings for cracks and missing parts.

The best way to locate a leak is to have the engine running and warm and then spray lighter gas around each joint in turn. If the engine rev's up you've found your leak.

Work your way through each possible joint one at a time and you should find it. I use a slightly flattened piece of brake pipe and some rubber hose from the can of lighter gas to provide a spraying 'wand' and allow a direct blast of gas into each area, especially those difficult to reach with large implements.

Might also be worth checking the wiring and connector to the airflow meter for any signs of corrosion or damage. you can do a quick fault find if you unplug the meter and run the engine without it.

if the engine condition is the same then chances are the meter or the connection to it is faulty

its also worth cleaning the airflow meter by removing it from the car and spraying the exposed sensor wires inside the tube with a brake or switch cleaner - ensure that the cleaner is one of the old fashioned, non Eco type that does not leave a residue

Expert:  Matt replied 12 months ago.

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. so if my answers have been helpful please rate my answer.

Customer: replied 11 months ago.
Hi,The answer turned out to be a faulty battery. It would start but the battery was depleted New fault codes turned up on the 13th. Fitted a new battery and it was all good. tricky one on how to rate
Expert:  Matt replied 11 months ago.

Well done for getting it sorted

always difficult to solve when you have misleading fault codes like this

just apply a rating as you feel is appropiate