How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 27148
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I have the MIL illuminated on my girlfriends 56 plate

Customer Question

Hi I have the MIL illuminated on my girlfriends 56 plate fiesta. I read the code and it shows P0200 Injector circuit fault. I've carried out some basic wiring checks on the injectors all four measure roughly the same resistance of 12 ohms and they don't appear to be shorted to ground. There is a 12V supply present and negative control voltage from the PCM. I've visually checked the wiring as best I could and have ensured the multiplugs are secure in the loom and on the PCM. The engine runs fine, I cleared the DTC but after three starts the fault code sets again. I have read some forums that the mondeo suffers from this code due to a bad earth on the battery ground under the battery tray. I tried to check these today but the captive bolt on the battery retaining bar is spinning and will require cutting out (nothing's ever easy is it!). I'm considering a set of second hand injectors and loom replacement but wondered if you have any experience of this code on the fiesta before I start changing components unnecessarily? many thanks.
Submitted: 1 year ago.
Category: UK Car
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

Yes,if there is a poor ground connection or ground wire this can cause this code here.I would make sure the grounds are clean and tight at the battery as well as leading from the battery to where they run and connect to.I would also check any ground wires connected to the body and frame as well as the engine block for any issues.If a fault is found with any ground wire or ground connection this will need corrected.

I would start with doing this before replacing any injectors or wiring.If this does not correct the issue then check over the injector wiring for loose or bent/damaged terminals at the injectors as well as the computer and if these are o.k. I suspect one or more of the injectors are intermittently setting the code and then replace the injectors.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete