How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24688
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I recently changed the A/T transmission of my E240 yr

Customer Question

Customer: i recently changed the A/T transmission of my E240 yr 1998.after the repair it started at the first attempt though it has been lying idle since july.howeverafter about 8 minutes of perfect idling the engine stopped and would not restart again for about 20 minutes when it started again but would stop again after 8 minutes and continued like that again and again.one thing that i noticed was that when the engine stpped the petrol pump did not supply and then after the 20 minutes resumed again for 8 minutes
JA: Thanks. Can you give me any more details about your issue?
Customer: the engine keeps cutting off after 8 minutes of perfect idling ang then you must wait for about 20 minutes before it woul restart
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $30) to post your type of question to UK Car Experts (you only pay if satisfied). There are a couple customers ahead of you. We can help you for less if you're not in a rush. Are you willing to wait a bit?
Customer: i can wait provided its not too long
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: UK Car
Expert:  Pete replied 1 year ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

One common component to cause a stall out like this here and a wait before it will restart again is the crank position sensor itself.I dont have the exact location of this sensor on your model but usually it is located on the back of the engine towards the top where the transmission bolts up.If this sensor was damaged or is failing this will cause this type of fault here.In some cases this sensor will not send a fault code making it difficult to diagnose fully but is the most common cause for this issue with it needing replaced.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete