How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, Shop Owner
Category: UK Car
Satisfied Customers: 6808
Experience:  17 years Shop Owner /Technician. 27 years experience,
29331485
Type Your UK Car Question Here...
Greg is online now
A new question is answered every 9 seconds

I have an LDV convoy minibus banana engine It has lost

Customer Question

I have an LDV convoy minibus banana engine
It has lost approx 3 litres of coolant in a week pipe into radiator is very hot one coming out not so is it the thermostat ,water pump or something else
Also battery light remains on initially upon starting need to give a little revs and it goes out battery replaced last week
Sounds like fan belt slipping when first started can stay on a good 2-3 miles if I depress clutch and hold for a few seconds costing when engine is warm it tens to stop the noise is this an alternator issue someone has adjusted the fan belt for me but it doesn't seem to have changed anything hope you can help
Submitted: 1 year ago.
Category: UK Car
Expert:  Greg replied 1 year ago.

How long does it take to start the engine when cold .

What colour smoke comes out the exhaust pipe when it does finally start up.

If you have tensioned the belt and still making a noise replace them .

This is why the battery light is staying ON for a few miles in the time of the belt noise .

If the top radiator hose is hot and the lower cold then remove and test the thermostat.

If its the first thermostat from new replace but still need to test . if its good check radiator for blockage.

Do a radiator flush if needed.

Still need additional information then please get back to me with the reply button, and not the poor or bad service, this way i can get back to you or suggest another expert if needed.

Your deposit does not pay me until the answer is rated in a positive way,
A bad rating does not constitute a refund.

If you are not happy or you have sorted out your problem before the answer then please let me know with the reply button .

Kind regards Greg.

Customer: replied 1 year ago.
belts have been replaced, a rev of the engine will take the battery light off, normally starts first time but is occasinally a little sluggish when cold will try thermostat and let you know
Expert:  Greg replied 1 year ago.

When you start the engine and you have the noise from the belts spray water onto the belts and let me know if the noise goes .

Greg

Customer: replied 1 year ago.
i sprayed WD40 on them last week and it didnt appear to have any real effect
if i leave the van ticking over in the morning for about 10-15 minutes it is rare that i get the problem i have been advised that it may be alternator but a test on it has been inconclusive hence the battery change as it was not wanting to start
Expert:  Greg replied 1 year ago.

No if belts are good and battery is new then the alternator has a problem .

You need to check the alternator output voltage on start up and when making the noise

you may have a bad alternator which are known to give out a noise when cold and quite down when warm .

bad bearing in the alternator, and a bad voltage regulator .

Greg