How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: UK Car
Satisfied Customers: 22518
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your UK Car Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Car won't start on first attempts....dpf light flashing

Customer Question

Customer: car won`t start on first attempts....dpf light flashing traction control light is one and engine light is on....mazda 6 3.0 di 05-08
JA: Thanks. Can you give me any more details about your issue?
Customer: hi, yes sure
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Mazda Experts (you only pay if satisfied). There are a couple customers ahead of you. We can help you for less if you're not in a rush. Are you willing to wait a bit?
Customer: yes I am
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: UK Car
Customer: replied 1 year ago.
The car was running fine then suddenly it lost power...that was last year....I kept driving the car since there were no control lights on....now it got colder and I have noticed the car has issues starting up (long start ups), I had the car checked by technician last year when the issue started and he said it could be the MAF sensor....I left this since the car was running although without the power, the car did not feel as powerful as before but I could live with that.....So yesterday, it was cold again, and the car almost did not start up....started on first attempt but it took a while...On my way on the road DPF light started to flash, engine control light on and traction control light on....vehicle went into what I suppose was a limp mode then after about 3-4 minutes it stopped and back to normal....when I say back to normal I mean that there was no limp mode however as I have explained the car does not run well for last year, it feels like half the kW it has but still better than the limp mode....Today, I have cleaned the MAF sensor, put it back in, no difference, all the control lights are still on and DPF flashing....I have also noticed that there is a build up around negative terminal which I have cleaned. Then, connected the battery again, made everything tight and tried to start car....it would not start...only on third or fourth attempt.....so I am not sure if these are more issues unrelated to each other or whether these point to single problem
Customer: replied 1 year ago.
my car basically feels as it has half the power, the engine is louder and produces more vibrations, car won`t reach higher speeds, trouble accelerating, DPF light is on, traction control light is on, DPF flashing...on top of that, it won`t start normally when cold.
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 1 year ago.
You do not have to call me since I live in EU...but your help would be greatly appreciatedIf the issue is with DPF, can blocked DPF also cause bad startups or no startup at all?
Customer: replied 1 year ago.
I thought this was meant to be chat....
Customer: replied 1 year ago.
To summarize:my car basically feels as it has half the power, the engine is louder and produces more vibrations, car won`t reach higher speeds, slow acceleration.......had all these for more than year, kept driving the caryesterday, the DPF light started to flash, engine light came on along with the traction control light and I have gone into limp mode for few minutes. the vehicle also won`t start properly in cold and this might be a different issue I am just not sure, can someone please help?
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

It sounds as if you have at least a couple problems going on. The DPF being restricted may be what is causing your loss of power all the time but there are more issues if it's going into limp in and having trouble starting.

The first step in diagnosing the problems is to see what fault codes are setting. Do you know what codes are setting?

Customer: replied 1 year ago.
Hello,No, I do not know the fault codes...I will take the car to garage next Friday for diagnostics.The car would rive with like half the power for the last year with no control lights on....so I knew I will have to take it to garage once but did not do so since the car drove fine without other issues....Occassioanly, for the past year, the DPF light would come on but drive on motorway has always sorted this out.I had this problem looked at by technician when it first started, they had checked the fuel pressure which was OK, then checked all the air ducting and had it dismantled apart and did not find any issues...The technician then said he presumes it will be MAF sensor but we did not have much time after that and I never came back to had it looked at again and fixed.Now, the car few days ago went into very very slow mode on my way home with the DPF light flashing and traction and engine light on...the car was almost no moving with the gas pedal depressed at some point and on idle, the revs would jerk up and down....then suddenly as I drove slowly, the car just shot of while I had the pedal depressed...I did not even restart the car, it was just kind of sudden change to previous state.The engine has had unpleasant vibrations and was louder in the past year which the last incident seemed to have worsened a little.As for the car not starting well....I bought top class battery last year so this should not be a problem...the car has very long startup, i do need to hold the key in ignition for like 4-5 seconds and then it starts... Occasionally, it won`t start until like 5th attempt... When I say cold, I do not even mean freezing temperatures since it is few degree Celsius above zero.I know that you would be able to help more knowing the problem codes but this will have to wait for a week. Until then, what would you check, or what would you think the issue could be as for the car driving bad or for the start ups?Oh and not to forget, in the last year of having the issue, I have also observed that when it is cold, then engine makes clicking tapping sound until it gets warm...I don`t know, maybe this is related. Can you please help?Lukas
Expert:  sprinkles08 replied 1 year ago.

I'm a full time tech and at work this morning, I'll get back to you as quickly as I can!

Customer: replied 1 year ago.
Hi,Can you please look into this? thanks
Customer: replied 1 year ago.
I will be back with the fault codes next week, until then can you please advise on the possible causes of the described issues?
Expert:  sprinkles08 replied 1 year ago.

There isn't a lot you'll be able to do without a scan tool besides a visual inspection. It sounds like the DPF may be restricted, which may have been caused by injector issues.

When it won't start what exactly happens?

Related UK Car Questions