How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 25834
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I have an MB C220 and my key fails to operate the ignition

Customer Question

Hi I have an MB C220 and my key fails to operate the ignition correctly and I have to disconnect the battery frequently. When I remove the key I get no 'de-energising' sound and the steering lock does not come on. Once this occurs when I try to reinsert the key I get no energising sound, no ignition warning light, etc. Any ideas?
Submitted: 1 year ago.
Category: UK Car
Customer: replied 1 year ago.
When I reinsert the key (after disconnecting the battery) I get the energising sound and the key/car operates as normal until I remove the key, no de-energising sound, key doesn't work, until I disconnect the battery again.
Customer: replied 1 year ago.
Dis-connecting the battery doesn't always work!
Customer: replied 1 year ago.
I've resolved this problem now, it's the ESL so no assistance required.
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

The ESL is a common fault that I have seen and had to replace before several times for this issue.I am glad to hear you have located and corrected the issue.Once again I do apologize for the delay and posted as soon as I saw your question myself.

Make sure you check the ESL wiring connection to make sure you have no damaged or bent connections or terminals as this can cause this issue as well as I have run into a couple of times.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete.

Related UK Car Questions