How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24729
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Mate I have a 2006 2.4 common rail transit with denso pump

Customer Question

hello mate I have a 2006 2.4 common rail transit with denso pump and injectors, symptoms was driving it cut out then wouldn't start although sounded like it was going to fire up any second, got it back to the workshop its had new battery new fuel pipes on the filter, injectors and pump removed and sent for testing came back erratic out put on pump and uneven spray pattern and leak off on injectors so £1100 later reconed the pump and 4x new injectors, put all back together with new timing chain as tensioner was on limit and chain was slack van fired up I turned it off it started again thought it was sorted only to go in today and its back to square one, it will fire on easy start if u play with the throttle and keep it going soon as you let off it wont idle and only some times starts straight back up again once it dies customer is nearly £3000 into the van and its still the same please help dony know what else to try cheers lee
Submitted: 1 year ago.
Category: UK Car
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

If you have not checked for any leaks in the fuel feed system this needs done.If a leak is found to where the injection pump is sucking air and fuel this will cause this issue here.In most cases this won't show up as a leak externally as the injection pump pulls a vacuum from the filter and tank so you will have to check the lines and fuel components to see if you can locate the source of any leaks.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete.

Related UK Car Questions