How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24668
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Pug 206 refusing to start. bought with a but intact turbo,

Customer Question

pug 206 refusing to start.
bought with a blown but intact turbo, had a new turbo fitted, failed to start had a new cat fitted. started and ran for circa 20 minutes, that was at pug garage. then failed to start, replaced 3 injectors and coded them with my trw easycheck. all faults now clear bar the egr valve circuitv a high p4050 maybe ? and one for the automatic transmission but its a manual.
i have another car with the same engine so i know the battery is fine as it starts the other.
i am just about to try swapping egr valve and starter to see if that fixes it (from the other engine) ive tried bsi reset 2 or 3 times and the easycheck says the ecu is unlocked and immobilsier coded. what are your thoughts on this mystery ?
regards
ryan
Submitted: 1 year ago.
Category: UK Car
Customer: replied 1 year ago.
I forgot to add that the side lights do work but no other system ie headlights etc, would this point towards the BSI ?
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

This type of fault here may be due to an internal electrical fault with the electronic ignition switch itself possibly.I have seen these switches fail on several models in the past before needing replaced to correct a fault like this.It is possible the BSI is at fault,the ignition switch and BSI electronics will need to be tested further to locate which is the cause here and to see if any other components are causing this issue needing replaced.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete.