How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Trainer/Master tech.
Category: UK Car
Satisfied Customers: 3498
Experience:  Trainer - master tech., SAE member
30385560
Type Your UK Car Question Here...
Billy is online now
A new question is answered every 9 seconds

Renault megane 2004 was running perfect but I lost the only

Customer Question

renault megane 2004 was running perfect but I lost the only key card I had so I bought an ecu kit from ebay which contained ecu ,steering lock, card reader and bcm I think it is called complete with 2 keys all from the same car.I fitted all the parts today all fine apart from when I put the key in and press start the steering lock works fine but I get a message that says injection fault and wont start.As I say the car was runnung perfect before I changed over the ecu kit.
Submitted: 1 year ago.
Category: UK Car
Customer: replied 1 year ago.
I called it a bcm I think it is called a uch..Just a thought Could there be any fault on the replacement ecu that could cause the injection fault?
Expert:  Billy replied 1 year ago.
Hello and Welcome! I'm Billy and i will assist you with your inquiry. Feel free to ask if any further info is needed.
My apologies for the delay, thank you for your patience.
There most likely is a fault with the replacement engine control unit... would you be able to check using a diagnostics computer for any fault codes stored?
when you try to start, does the engine turn (starter operate)? or you get nothing?
Customer: replied 1 year ago.
Hi Billy I get nothing when I try to start car there are no fault codes stored in the new ecu.I changed the ecu back to my old one which obvously didnt work but at least the engine turned over then said immobiser fault as expected then I put the new ecu back in and got the injection fualt again.
Customer: replied 1 year ago.
I contacted the guy who I got the replacement ecu kit from and he said that the car that it came from was running perfect with no faults.The only thing it said was "change oil soon"
Expert:  Billy replied 1 year ago.
Hello again,
Are you getting communication when you access the ECU? and still no faults, while on dash it displays a fault???
Is it the same part number as the old one?
Customer: replied 1 year ago.
I did not match any part numbers to my old one....
Expert:  Billy replied 1 year ago.
You need to check the part numbers. As if this is a different ECU, it would not work.
Customer: replied 1 year ago.
do only the ecu numbers have to match or does the uch numbers have to match too.
Expert:  Billy replied 1 year ago.
Hello,
You had the parts from a kit together. So if the ECU matches the engine should start.
So i would first check the ECU numbers, get back to me on those, if you need further info, so we proceed as needed.
Regards,
Billy

Related UK Car Questions