How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Your Own Question
Mike
Mike, UK Car Mechanic
Category: UK Car
Satisfied Customers: 39198
Experience:  Hi, I am a Car/ vehicle technician of 34 years. 29of -running my own repair/diagnostic business.
9261905
Type Your UK Car Question Here...
Mike is online now
A new question is answered every 9 seconds

6: Hy, i have a problem with my car the negine works 20-25

Customer Question

Hy, i have a problem with my car the negine works 20-25 minutes ok then it stops and you cant start till next day...
Submitted: 1 year ago.
Category: UK Car
Expert:  Mike replied 1 year ago.
Hello and Welcome - My name is ***** ***** Im happy to help / advise..This sounds very much like you have a restriction in the exhaust system.... you should start though by having the EGR valve / system removed - checked and cleaned... likley this will be all clogged.You can get a restriction in the exhaust other than the Dpf system that you had... when the car is playing up- ie, not running - a back pressure test should be done to confirm / fix this for you.Let me know how you go..and / or let me know if you need anything further on this..~>>~~~ Meantime - Please do click on the "Exc / Ok rating" for me at this time.. "Thank you" in advance for that ... Note that you can get back to me anytime at all after doing the rating - it doesn't close you out -- Best Rgds, MIKE.
Customer: replied 1 year ago.
Checked lot of things like live logging,error codes,nothing shows up.When the car starts up it runs for like 20-25 minute,after it stops you cant start it back till next day usually.So my car is not starting now up, i tryed to see if fuel comes to the engine after the filter but nothing,just you can fill vacuum on the ALuminium pipe,on the return pipe is going fuel.Next check was the fuel pump same i take down the hose and tryed to start the engine but nothin is comming out from the pump,you can feel just vacuum on the black hose.
Expert:  Mike replied 1 year ago.
Hello there - I wasn't aware you had deduced a fuel supply problem - that doesn't add up with the dealer telling you it was dpf sensor issues at all... I cant understand why they would go there if you have no fuel coming up.If this is so - ie- no fuel coming up - then you have to find out why. You need to test the system fully - starting with checking the actual pump - and the wiring to it. There have been known issues where they lose their power supply through engine vibration / movement causing bad connections on the circuits / plugs etc - so you need to check all that.Again if you have for sure....a fuel supply issue - you need to check as above.. then if ALL checks out as ok, the pump itself is suspect..-- Thats the way forward in this case now then. You will need garage / specialist help - I would suggest the latter rather than dealers etc - as they have the experience and importantly, the special test equipment to check the pump itself etc... that is a specialist job - not even a dealer job.... Again, you can let me know how you go..Please do click on the OK / exc ratings for me at this time - Thank you again..and get back to me anytime.Best Rgds, MIKE.
Customer: replied 1 year ago.
checked fuel pump relay,fuse both seems ok. tomorrow i will try to take out the fuel pump and connect to 12v to see if its working,the only thing what i dont understand is how can he start up once per day for 20 min,after that he will not start all day,it seems to me something is cutting out the fuel pump,or the fuel pump is getting blocked.Can the egr do something like this,or the temperature sensors from the dpf?cause all three sensors shows just 700 degree all the time,even when the engine is at 30 degree.
Expert:  Mike replied 1 year ago.
Hi again..Yes this is evidently an intermittent fault -and these are the hardest to find for obvious reasons.. The Egr will not cause the fuel pump to cut no - nor will the sensors. The only sensor that will do that is the oil pressure sensor if faulty - or if you have low oil / pressure.Given that you are now giving me that info now too - re the sensors readings... I feel this is likely a control unit fault- Do what you are planning by way of tests - but if you don't find anything conclusive, you may find you will need specialist help / with test equipment for this. = Again let me know how you get on - Im always happy to help as you progress .. I would appreciate your clicking on the OK ratings for me at this point please..Kind rgds, MIKE....