How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Trainer/Master tech.
Category: UK Car
Satisfied Customers: 3498
Experience:  Trainer - master tech., SAE member
30385560
Type Your UK Car Question Here...
Billy is online now
A new question is answered every 9 seconds

E280: I own a a Mercedes W210 E280 limousine stretched by Jankle,

Customer Question

I own a a Mercedes W210 E280 limousine stretched by Jankle, Currently the boot fails to open by switch in centre consul, or by key fob, the courtesy lights fail to light up regardless of which door is opened The central locking alsso is defective. I suspect fuse 19 but cannot locate it under the bonnet. There is however a fuse 19 under the rear seat. What do you suggest.
Submitted: 1 year ago.
Category: UK Car
Customer: replied 1 year ago.
I am certain that there is one simple solution to all these problems as fuse 19 is the common factor. The tech data claims fuse 19 is under the bonnet. I could be wrong they could be wrong
Expert:  Billy replied 1 year ago.
Hello and Welcome! I'm Billy and i will assist you with your inquiry. Feel free to ask if any further info is needed.
Let's start by checking the common cause first:
Check the fuses under the seat and in luggage compartment (all of them).
check this technical service bulletin:
Known fix
Body
Electrical
Affected vehicles
All models.
Problem
Boot lid will not release with the key remote control or centre console button.
Cause
Load area lamp not working correctly.
Remedy
Ensure load area lamp operates correctly.
Kindly get back to me with your findings, or if further assistance is needed so we proceed accordingly
Regards,
Billy
Customer: replied 1 year ago.
I have checked all fuses in all areas under bonnet, under rear seat, behind light switch on dash board. All serviceable.
Load area lamp, would that be the light in the boot that comes on when you open it? It works fine.
Expert:  Billy replied 1 year ago.
Hello,
The load area lamp is the light in that comes on when you open the boot.
The bulletin says: "not working correctly", i should explain:
ot stays on, even with boot closed. Can you put a camera, mobile phone or something inside the boot to verify that it is turning off when the boot is closed?
Customer: replied 1 year ago.
I'll try that, but cant see the connection to all the other problems.
Expert:  Billy replied 1 year ago.
The problems are most likely connected. But we're not sure about that.
So the best way to go, would be checking the most common failures and proceeding accordingly.
Customer: replied 1 year ago.
The boot light stays on, I'm amazed.
Expert:  Billy replied 1 year ago.
Hello,
Try removing the bulb, and let's see what happens...
Customer: replied 1 year ago.
I took it out to save battery life, over the past few weeks the battery has been getting drained; now I know why. Bulb removed makes no difference at all.
Expert:  Billy replied 1 year ago.
Hello,
now we need to check the wiring.... do you have the infra red remote?
Customer: replied 1 year ago.
would that be a wee red light that appears on the key fob? I changed the batteries on the key fob for brand new ones.
Expert:  Billy replied 1 year ago.
That would be the light at the front of the fob. Which you point towards the sensor at the door handle, or the sensor at the boot.
If you can (usually) lock or unlock without pointing at these (point at sky and try) then you would not have the infra red system.
Customer: replied 1 year ago.
I guess I got an infra red system then, used to be able to point at the general area of the car and open the boot, lock or unlock it.
Expert:  Billy replied 1 year ago.
Hello,
I would start by checking the wiring at the boot (for the switch and for the actuator), make sure the connectors have tight and clean contacts, and the wires are good.
Having done that, and if the problem persists, you would need to check the wiring, starting at the RCL module (central locking module).
This module should be under the front passeger footwell, or under the driver footwell, removing the carpet will reveal the location.
For the wiring checks, i will include the diagram, so you can check wiring integrity (continuity):
https://drive.google.com/file/d/0B6Zgf4dbmODzQUMxQkQ2bTBuRW8/view?usp=sharing
Kindly get back to me with your findings, or if further assistance is needed so we proceed as necessary.
Regards,
Billy
Customer: replied 1 year ago.
Would the switch and the actuator be attached to the boot lock mechanism.? I took the boot lock mechanism off and put a dose of WD40 down the key channel as the key was initially unable to turn within the barrel. The unit looked reasonable and the wiring was intact.
Expert:  Billy replied 1 year ago.
Hello,
The switch and the pneumatic actuator are within the lock mechanism.
Did you have the problem prior to removing the boot lock mechanism?
Customer: replied 1 year ago.
No the limo went out with everything working, some time during a wedding gig, my driver told me the boot would not open. I suggested the use of the key fob infra red button,and then the key, but that would not work as the barrel had seized up. Back at base and a liberal dose of WD40 the key opened the boot. I checked fuses and noticed the courtesy lights had also ceased to function.
The boot light being on I suspect has been an ongoing problem, as I have quite often had to recharge the battery when the limo has not been out for a week or two.
Expert:  Billy replied 1 year ago.
Ok,
So the light was already problematic, adn you used the WD40 cause the boot wouldn't open using the switch.
Try checking the courtesy light bulbs, if any was blown... and were there any liberal doses of liquids (champagne or other) poured around inside the car? especially near the central locking module?
Customer: replied 1 year ago.
the courtesy lights above the drivers centre consul come on when manually switched. There has never been a liberal dose of any liquids spilt within the limo. I'll check the4 condition of the door courtesy lights.
Expert:  Billy replied 1 year ago.
Hello,
I would also check the module (under the carpet), at least its wiring, make sure you have tight and clean contacts on that.
Customer: replied 1 year ago.
Wedding on today, I'll not have time to investigate that aspect till late afternoon.
Expert:  Billy replied 1 year ago.
Take your time.. i will be waiting...
Cheers
Customer: replied 1 year ago.
Been busi , now have checked out all the contacts that I can find within the foot wells, nothing has changed, still the same symptoms.
I also rechecked all the fuses, with my AVO.
Expert:  Billy replied 1 year ago.
Did you check the RCL module, under the carpet?
Customer: replied 1 year ago.
Yes took up the carpet, took as many of the connections off and put them back as I could, just in the spirit of make and remake. Nothing seemed out of place or not as it should be. Found a few others that I have no idea what they do so I pulled them apart as well and put them together again. Everything looked fresh, no sign of corrosion at all, connections looked clean.
Expert:  Billy replied 1 year ago.
Hello,This is getting weird, as the system consists of the RCL, the pneumatic module, the door locks and switches and the wires.Is the courtesy lamp bulb good? was this and its connectors checked?
Customer: replied 1 year ago.
I have resolved some of the problem; In the spirit of brake and remake all connections, I took the air pump mech out from beside the battery, under the rear seat, broke and remade all the connections, one of them caused the pump to make the buzzing sound, and the courtesy lights on the open doors came on. I used the interior boot opening switch which worked and the boot opened. Every thing is now almost as it was before, except the interior courtesy light above the driver fails to come on when the door is open, but works on the switch. The open the boot function on the key fob device does not work. The central locking/unlocking works on the key fob device. Progress of sorts I'm a much happier person now, I can lock up and leave my limo without the worry of it being nicked.
Expert:  Billy replied 1 year ago.
That is some good news.... finally a break... now let's concentrate on the courtesy lights, would you be able to check their wiring (as per diagram)?
Customer: replied 1 year ago.
I will take a good look at the wiring. I was even thinking of taking the drivers courtesy out of the system and re wire it independently.
So that door open light on, door closed light off.
Expert:  Billy replied 1 year ago.
No need for independent wiring... we can use the existing wiring (check continuity and wire as needed)... but i think the problem should be sorted by wiring and connector checking..... the wiring at the courtesy bulbs most specifically.