How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Billy Your Own Question
Billy
Billy, Trainer/Master tech.
Category: UK Car
Satisfied Customers: 3498
Experience:  Trainer - master tech., SAE member
30385560
Type Your UK Car Question Here...
Billy is online now
A new question is answered every 9 seconds

Focus cmax: , I'm hoping you can help, I have a 2004 cmax

Customer Question

Hi, I'm hoping you can help, I have a 2004 cmax 2.0tdci with EHPS . a few months ago 'steering assist failure' appeared a few times, but with no loss of steering. After a day or so it progressed to giving the warning every few seconds. I work at a Honda dealership and they put it on a snap on scanner fault c1955 came up steering angle sensor/ open circuit. They replaced the sensor fault code still came up but this time just open circuit. the warning message comes up less ie only after turning the steering wheel now, slight turn to the right or a bigger turn to the left triggers it. I took it to a Ford dealer to see if the sensor needed coding, they said no . They suggested I change the abs module and if that didn't cure it then change the ehps module. My car doesn't have traction control As you are aware these cost a lot of money. I did buy a genuine ford ehps pump/module but they don't want to fit it. can I fit it myself or does it have to be coded to the vehicle like they say
Submitted: 1 year ago.
Category: UK Car
Expert:  Billy replied 1 year ago.
Hello and Welcome! I'm Billy and i will assist you with your inquiry. Feel free to ask if any further info is needed.
My apologies for the delay, thank you for your patience.
It would work if you install it. But i don't think that's the problem.
Are you saying you have no ABS on the vehicle?
Customer: replied 1 year ago.
no, ABS works, no warning lights or codes stored for abs. though I notice that the car has to be moving even just slowly to trigger the warning message. the warning light and message goes after a few mins. until you turn the wheel again more than a few degrees
Expert:  Billy replied 1 year ago.
Hello,
Even if ABS works, it can cause this.
I would start by checking and cleaning the connectors on the ABS module, and the EHPS module.
If the problem persists, and since you have the EHPS module, and want to install it, you can do this, and it should operate.
Kindly get back to me with your findings, so we proceed accordingly.
Regards,
Billy
Customer: replied 1 year ago.
don't you need to downloads codes from the old units and put back into the new units
Expert:  Billy replied 1 year ago.
Hello,
The fault codes is excatly what we're trying to prevent here.
The new unit will operate. Hopefully the fault is from the old unit so the problem is gone. But i recommend checking the connectors as indicated above, before replacing.
Get back to me with the results...
Cheers,
Billy