How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 27662
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Vivaro: Have vivaro 54 plate 1.9 cdti, problem today, non start

Customer Question

Have vivaro 54 plate 1.9 cdti, problem today, non start due to air in fuel, when primed it started with difficulty but ran ok, put fuel in again and run around for a few miles, stopped and started ok but when left for ten minutes needed primed again, other recent things oil sensor warning comes on frequently although oil is ok, and engine recently wouldn't stay idling for long if left idling at lunch etc
Submitted: 2 years ago.
Category: UK Car
Expert:  Pete replied 2 years ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
My info is limited on your model here but I see no one else has responded and thought I would see if I can help here.
Inspect the fuel supply from the fuel tank to the engine and fuel filter and pump to see if there are any fuel leaks at all.If any leaks are found this will cause the pump to suck in air and fuel and cause this issue here.
If this is all found to be o.k. this can be the fuel pump/injection pump itself at fault needing replaced as it may not be producing enough pressure when cranking over to start the engine.
Thanks Pete
Customer: replied 2 years ago.
Found leak at filter but now has smoke when accelerating, still same to start needed primed, don't know if electric tank pump continually has to run after hp pump on engine cranks on
Expert:  Pete replied 2 years ago.
Usually when there is an electric low pressure pump this does run with the engine running to keep the pressure to the high pressure pump.If it isn't running or has low pressure then the low pressure pump usually needs replaced.
The smoke issue can be a sign of one or more fuel injectors allowing to much fuel into the engine over fueling the engine.I would have the fuel injectors tested to see if this is the cause here and the affected injectors replaced.
Thanks Pete
Customer: replied 2 years ago.
This wasn't the fault it was a wiring problem so how do I rate that
Expert:  Pete replied 2 years ago.
I apologize my answer wasn't the correction here.You can rate how you want here,I appreciate an o.k. to excellent rating if possible.If there is anything else I can help with here let me know.
Thanks Pete

Related UK Car Questions