How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Car Enthusiast
Category: UK Car
Satisfied Customers: 24720
Experience:  Over 17 years experience diagnosing and repairing automobiles.
14928985
Type Your UK Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Sprinter 2.7: I have just purchased a Mercedes Sprinter 2.7

Customer Question

I have just purchased a Mercedes Sprinter 2.7 5 cylinder diesel on a 2004 plate. I was told it would go quickly despite the motor home body, but it really struggled up hills on the journey home, but performed better after a 15 minute break
Now I suspect the motor home has been sitting idle all winter so could have stale diesel, but that should have worked through after a fuelling and 100 mile journey.
I have oiled moving engine support systems such as throttle cables etc, and cleaned a very dirty air filter which will be replaced asap.
The van when stationary will not rev as high as 3000 revs. I assume this is deliberate. However the engine as allegedly only done 32000 miles so should not feel as tired as it did yesterday.
What would you suggest as priorities to get to the bottom of the lack of power.
Finally I can see the van needs an oil change and will replace oil and fuel filteron this service.
Submitted: 1 year ago.
Category: UK Car
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
I would start with replacing the fuel filter itself.I have seen this filter cause this issue when it restricts partially and had to replace it several times before.
Thanks Pete