How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, European Car Expert
Category: UK Car
Satisfied Customers: 394
Experience:  ASE & Bosch Certified Master Tech. Over 30 years experience.
13230946
Type Your UK Car Question Here...
Marty is online now
A new question is answered every 9 seconds

I have a Ford 6.0 4x4 F350 2004 Duly that is modified.Bigger

Customer Question

I have a Ford 6.0 4x4 F350 2004 Duly that is modified. Bigger injectors, bigger turbo, steedspeed manifold, rebuilt FICM 48V, banks intercooler, AFE intake, suncoast transmission and much more... The truck runs well but whenever I race and launch the truck, I will get one good run and it will not launch a second time because I will get this code: P0500. Then it will take very long to build boost, the rpm will not go beyond 2000 and it will launch very very slow the second time. But when I drive away, it will drive normal, boost normal, rpm will be normal, it will work like that for months, normal no problems, only when i try to race and stand on the brakes to launch the truck the P0500 code will appear. I purchased the AE scan tool, to try and help myself fix this problem, with no avail. I changed the complete transmission wire harness all the way from the pcm to the transmission, I changed the speed sensor that is on top of the differential that is at the back, I changed the speed sensor that is at the rear of the transmission, I changed the brakes master cylinder that came with a new brakes pressure switch. But the problem is still there. I also bought a new anti-lock brakes module, as I thought that this would be my last option but I think the sales person at Green Ford sold me the wrong part. When I install it my ABS light came on and I retrieved this code: B2477. He sold me part #: 5C7Z-2C219-B which I think its for the single rear wheelXXXXX but he told me that is the only part number he has for my vehicle. The part number for the one that came off my truck is 2C34-2C346-BE. Does theXXXXXduly's come with a different module, to the single rear wheelXXXXX Can you please help me with this problem? What should I do next? I also pulled these codes with the AE scan tool: U1041, B1352, B1869, Do you think these codes are in relation to my present problem also? How can I fix these problem codes? Regards, Martin

Submitted: 3 years ago.
Category: UK Car
Expert:  Walt-Mod replied 3 years ago.
Hi,
I'm a moderator for this topic. I've been working hard to find a Professional to assist you right away, but sometimes finding the right professional can take a little longer than expected.
I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.
Thank you!
Customer: replied 3 years ago.

Hi walt,


i'll continue to wait for a day or two.


 


Regards.

Expert:  Walt-Mod replied 3 years ago.
Thank you for your continued patience. We will continue the search for a professional for you.
Expert:  Walt-Mod replied 3 years ago.
Thank you for your patience, your business is very important to us, we are waiting on the Professional with the right expertise to come online. Feel free to let us know if you would like us to continue searching for a Professional or if you would like us to close your question. Thank you for your understanding!
Customer: replied 3 years ago.

Hi Walt,


seems like no one can help with my question.


Could you please issue me a refund to my paypal account.


Regards,


Martin