How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris VW Master Tech Your Own Question
Chris VW Master Tech
Chris VW Master Tech, UK Car Mechanic
Category: UK Car
Satisfied Customers: 327
Experience:  City & Guilds 1,2,3 VW Master Tech Cars & Vans, VW License Tech, Nissn Hi Tech, Rover Accredited
10684209
Type Your UK Car Question Here...
Chris VW Master Tech is online now
A new question is answered every 9 seconds

Peugeot: petrol..misfire..ecu..fuel rail and all four injectors

Customer Question

peugeot 206 1.4cc petrol on a x'reg problem is misfire at idle and when reving engine scanned ecu got fault code p0267 injector cylinder number 3 circuit.replaced fuel rail and all four injectors with ones i got second hand from a breakers.car is still the same removed rail and replaced cylinder no3 injector with one from the original rail that worked still the same i am classing cylinder no1 at the flywheel end is this correct also is there any known faults where the problem is the wiring loom that are common and to add upon removing the original rail and injectors the seals where split and the no 3 injector was black with soot on the end where the rest were clean.
Submitted: 5 years ago.
Category: UK Car
Expert:  Chris VW Master Tech replied 5 years ago.

Chris VW Master Tech :

Hello and thankyou for using just answer. 1st of all cylinder No 1 is closest to the cam belt end not the flywheel end, so it will go 1,2,3,4 starting at the cambelt end, also these engines are prone to the coil pack failing, although you have put a 2nd hand one on it , can you be sure this was in full working order, it may be poss you have replaced the incorrect injector due to thinking that cylinder 1 was at flywheel end, so you mat want to check that again, also when were the spark plugs last changed, as from what i can see from your description you havent changed these, and they should have been the 1st thing you checked, and also has anyone carried out a compression check on the engine to see if you have a low compression on any 4 of the cylinders, if this is the case then you are looking at an internal engine fault, but please try the other options 1st, hope this helps Chris