How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Merc-Dude Your Own Question
Merc-Dude
Merc-Dude , Mercedes Diagnostic Technician
Category: UK Car
Satisfied Customers: 91
Experience:  10 Years Mercedes Training
32900983
Type Your UK Car Question Here...
Merc-Dude is online now
A new question is answered every 9 seconds

2001 mercedes c320: wont start..parked..dash lit..clicking noise

Customer Question

my 2001 mercedes c320 wont start. it was going fine and was parked up for 10mins , when i returned and turned the key the dash lit up as normal, the radio was on and that was it. no clicking noise nothing , wont even try to start. the panel said no malfunctions but the service light comes up showing 2 spanners and saying that it has not been serviced in 6100 miles, although it had a major service 2 months ago but the garage did not have the software to reset the service warning lights. it also had a new gear selector fitted last week. please advise.
Submitted: 6 years ago.
Category: UK Car
Expert:  Merc-Dude replied 6 years ago.
Hi there What was the reason it had a selector fitted was it for none start? Is there a Drive letter in the instrument cluster to say if it is in park,Dive etc ?
Customer: replied 6 years ago.
the car was stuck in park. there is no letter to show it is in park until the key is turned fully and the engine fails to fire then the light says it is in park
Expert:  Merc-Dude replied 6 years ago.
Hi there again So with the ignition on you have a drive letter P but the vehicle will not turn over and there is no click. With the ignition on you can pull the selector out of park. Sorry for all the questions but I need to gather information Cheers Dave
Customer: replied 6 years ago.
seemed to be stuck in park
Expert:  Merc-Dude replied 6 years ago.
Hi there if the vehicle is stuck in park and it has just had a selector fitted is sounds like there is no start enable comand coming from the Electronic ignition switch to the engine control unit. This would need to checked with a scanner or a Mercedes star machine. There are a some fuses that you can check in this circuit ,fuse 52 and 57 in the front fuse box under the hood and fuse 31 in the cockpit fuse box at the end of the dash .these fuses are for start enable If these are ok then you need to see if the start enable comand is present before going and futher . Please click accept if my answer has helped you.
Customer: replied 6 years ago.
52,57,31 fuses are all fine. what do you suggest now
Expert:  Merc-Dude replied 6 years ago.
Hi there an easy way to check if the ignition supply is getting through the front fuse box(SAM) .In the front fuse box you will find a purple wire coming from the plug which is push into the top of the fuse panel.This wire is about an 1/8 of an inch thick and supplies the starter motor solenoid when the key is in the crank position 3 .If you put a test lamp or multi-meter probe into the wire and the other end of the tester to the body, then try to crank the engine .If the test light lights then power is getting to the starter and the starter is at fault. If there is no power here in the cranked position them the you will have work backwards through the starter relay 'S' in the same fuse box and check if this has power.If there is still no power energizing the relay .Then the fault will be within the CAN bus and will need to be checked with a scanner or star machine to see the fault codes and also have the start enable comand checked from the Ignition switch and engine control through to the shift module. Hope this has helped